Internet & Home Phone
Discuss and/or ask questions about your TELUS Internet and Home Phone.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Latest topics

Resolved! Problem connecting devices to Telus modem

I have a Honeywell thermostat which connects to the internet via a redlink internet gateway. I have issues connecting the redlink to the internet (via cable) and I was told it is a common issue with the white Telus modem. Does anyone have similar iss...

Booster drops out every 60 minutes

I have a Telus Wifi Hub and one Booster set up.Every 60 minutes the booster drops off the network, shows a red light, then a blinking blue, then solid blue as it comes back up. The interruption is enough to drop Zoom and VOIP calls.The Wifi Hub is fi...

bigeh by Just Moved In
  • 394 Views
  • 0 replies
  • 0 kudos

Where to Start?

I'm looking to switch our mobile and home services to Telus but I don't know where to start. I know we can save if we bundle but not one Telus store does it all. Do we start with getting Mobile set up and then bundle and save when we sign up for home...

Resolved! T3200M has blank Bridge Mode option?

On my T3200M when I go into Advanced settings to turn on Bridge Mode, there are no checkboxes available to choose Enable or Disable.I should be able to enable it right?

ksignorini by Friendly Neighbour
  • 1041 Views
  • 3 replies
  • 0 kudos

Resolved! One Main line coming to house but seperate modems

We have a telus line coming to our house, however it goes to the basement where they have the Telus internet. I'm living on the main floor and using Shaw but decided to switch to Telus, can I use that main line but have seperate modems? Will this aff...

MaxYuuki by Just Moved In
  • 891 Views
  • 3 replies
  • 0 kudos

Resolved! Upload Speed on PureFiber

Hello I seem to be having an issue with my Telus PureFiber WiFi Hub. My current setup is the PureFiber WiFi Hub connected to my Linksys Velop MX5300 WiFi 6. THe issue is, when I test the connection from the LinkSys node connected to the PureFiber Hub...

Local DNS on Telus Wifi Hub

Local DNS resolution does not appear to work on my Telus Wifi Hub, firmware v3.00.20 build80. I've set Domain Name to "lan", and DNS Server to the router's lan address of 192.168.1.1. I have another computer for which the hub has a hostname of "oct",...

dsjstc by Just Moved In
  • 854 Views
  • 1 replies
  • 1 kudos

Customer Service

Hello everyone,Has the customer service been an issue for anyone here? It has been a debacle in my case.I have been a Telus customer since 2001. I moved to my new place in August of 2020 and I am still waiting for an optik TV box that I had ordered r...

Qamar by Just Moved In
  • 680 Views
  • 1 replies
  • 0 kudos
Friendliest neighbours