Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pik TV Unusable: "Check your internet connectivity."


Good morning, folks –


Just hoping someone might have a useful insight here for me. I'm a new Pik TV customer. It was working "well" for me for about a week, but now I can't access it at all with my Android box.


I have tried wired and wirelessly with a connection speed of ~200 Mb/s. I have cleared the cache, data, etc for the app. I even caved and did a factory reset on the box. I get this error every time I launch:



Other apps that require internet work on the box. I can access Pik through my phone.


The Pik TV app is version 1.92.201.



Considering everything else you've done, I'd suggest restarting your modem and router.  Sometimes (for whatever reason) when the IP addresses, etc. populate the device, it leaves out the DNS server numbers.  I've seen it happen.  If you haven't done that modem restart, try it and see.

Thanks, @SH1 – I'll give that a try tonight. Oddly, on the box itself under status, the box seems unable to list its own MAC address (shows something like 02:00:00:00:00 whatever). I can see the correct MAC registered on the network. It's weird and could be unrelated, but since the MAC is an important component to networking, I did think it was peculiar.

That is odd.  Also, if you're using a VPN, try disabling it.  Another thought.

Unfortunately, rebooting the modem and router didn't help. I'm not on a VPN either. (N92.2 release btw)

Highly disappointing. You can see that the log in screen is behind the pop up, if only you could dismiss it and give it a go...

If other apks that need Internet work fine on your Android box, meaning the box is connected properly to the Internet, then the only other thing I can think of is that somehow the permissions set for the PikTV apk aren't right.  There's possibly something you need to give permission to where the permission is denied.  Maybe go to the app's permissions settings on the box and check the permissions for it.  Also check network permissions.

Also, make sure the date and time on your box is correct.


And then there's this last idea I had -- go to Settings > Network & Internet and click on Wifi.  When your Wifi is connected, click on your provider and click on the "Forget" button.  Make sure you have your login info because it resets your Wifi connection.


Maybe one of these other things will work?  I hope so...


I had this exact problem.


Did a full factory reset - same problem

Did it again - same problem


All other internet and network apps/functions worked fine (Plex, YouTube, etc).  Nothing blocked in the firewalls.  iPhone and PC web browsers work fine.


Called Telus tech support and went through the basic troubleshooting. They basically told me the media box is a piece of s##t which is why they neither offer it nor support it anymore.  So I transferred to customer service and dickered with them for a while.  They offered to send me a refurbished media box (no thanks) or an Apple TV 4K if I signed a 2-year service agreement.


Agreement signed.  AppleTV arrived.  It works fine (awful remote).