No data on TELUS's 3G network?

Reply
Amethyst3
Connector

Hello! 

 

We're roaming on the TELUS cellular network, and our phones are with another carrier.  (Relocated, still on contract with this carrier.)  We've noticed recently that we have no data when on TELUS's 3G network.  Data works on LTE.  Is anyone else having any issues with TELUS's 3G network?  Trying to troubleshoot the problem.  It's 2 different phones, so it's not the devices that are the issue. 

Community Power User
Community Power User

What type of phones? Are they from outside of Canada?


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Community Power User
Community Power User

You may have to reset your network settings so the APN of th phone resets to use data on the Telus Network. Your phones may be still trying to use the APN of your former network.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Amethyst3
Connector

iPhone 8.  Purchased in Canada, Sasktel is the carrier. 

Amethyst3
Connector

We've roamed all across western Canada and the U.S.,  with LTE and 3G on Telus, Bell, Rogers, AT&T, T-Mobile, and smaller local carriers in the U.S.  3G is slower, but has always worked until the last few days.  DH's phone was iffy with the 3G, data would cut in and out.  Today, we were in a weak signal area and lost connection entirely, then were on 3G instead of LTE when the phones did get signal again.  I had turned my phone off and on a couple of times during all of this.  Spouse did not.  Both our phones got back to LTE on their own.  We were unable to access data when we were on 3G. 

 

I am aware that some Canadian carriers were having issues last week, I was wondering if Telus is now.  I contacted my carrier, Sasktel, and they said they are not having any problems and believed the problem must be with Telus's towers. 

 

Community Power User
Community Power User

If LTE is working, I wouldn't be overly worried about 3G. Where exactly are you roaming where you're on the Telus network? 

 

Last time I was in the US, 3G wasn't working for me on T-Mobile or AT&T but LTE worked fine. Haven't had any issues in Canada.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy