Showing results for 
Show  only  | Search instead for 
Did you mean: 

**Internet Connectivity Mystery After Power Outages - Seeking Insights**


Hello fellow forum members,

I've recently encountered a baffling internet connectivity issue in the Cedar Hills Surrey area, particularly following power outages. I'm reaching out to see if anyone in our community has faced a similar challenge or can provide valuable insights.

**Description of the Issue:**
- **Website Accessibility**: When connected to Wi-Fi, certain websites like and don't work at all, while others like function normally. The issue remains consistent and doesn't have a discernible pattern.
- **Smart Device Dilemma**: Alongside this, my smart home devices exhibit mixed results when connecting to the network. While some devices can establish a connection, others, including those from,, and, face connectivity issues. Additionally, I can't access the websites linked to these non-connecting smart devices while connected to Wi-fi.
- **Selective Connectivity**: Among my smart switches, only one Kasa smart switch successfully connects, while the rest remain unable to establish a connection.
- **Access Point Anomaly**: In my network, I utilize three TP-Link EAP225 access points. Two of them function correctly, but one refuses to connect. This issue persists despite numerous attempts to resolve it.
- **Vonage VoIP Phone**: My Vonage VoIP phone worked seamlessly before I initiated troubleshooting with Telus support, but it has since lost its connection.

**Troubleshooting Attempts:**
- I've reached out to Telus technical support, and they've escalated the issue to their senior tech team.
- We've undertaken a series of troubleshooting steps, including IP address resets and hardware checks. Unfortunately, these efforts haven't yielded a solution thus far.
- **Hub Replacement**: During a previous occurrence of this issue, the technician replaced the hub, even though the problem resolved itself before their arrival. They left me with the old hub as a precautionary measure, but this hasn't resolved the problem either. I've even tried swapping the new hub with the old one, but the issue persists.

It's also noteworthy that my PC, which is hardwired to the network, experiences no connectivity issues and can access all websites seamlessly.

I'm eager to learn if anyone within this forum has encountered a similar challenge or possesses insights to offer. If you've had interactions with Telus support or have any relevant information, please don't hesitate to share.

Your contributions can play a pivotal role in determining whether this is an isolated incident or a matter affecting a broader group of users. I'm profoundly grateful for your assistance!



Hello again, forum members,

I'd like to follow up on my initial post.

Regarding Telus Wi-Fi Boosters: In my previous post, I mentioned the challenges I've faced with certain websites becoming inaccessible and the issues with smart home devices and switches. However, I inadvertently omitted an important detail about Telus Wi-Fi boosters. After power outages, these boosters have trouble reconnecting, and their indicator lights persistently blink blue, indicating the see the network but are unable to connect. 

Community Power User
Community Power User

I would be looking at your wifi boosters and possibly your router.


It's normal for the boosters to blink blue for a short period of time after an outage. Once your router is back up the boosters should connect to the router and stop blinking blue. If you continue to see a blinking blue light on the booster and your wired connection is fine there is an issue between your router and booster. First thing I would do at this point would be to power cycle the problem booster to see if that clears up the problem.

Just a long time customer hoping to help.

I contacted customer support this morning, and after performing additional troubleshooting steps, we managed to get the boosters back up and running. One of the key solutions that seemed to work was simultaneously pressing the WPS button on both the hub and the booster several times. Following this, the boosters successfully reconnected, and all the TP-Link WAPs also regained connectivity. The Vonage phone started functioning again after a few reboots and switching the Ethernet port connection on the switch.

At present, everything appears to be operating smoothly 🤞. However, it's worth noting that I encounter this issue consistently every time there is a power outage. I was previously informed that the boosters should automatically reconnect after an outage if they were added in the "Telus Connect" app. Unfortunately,i haven't been able to add the boosters to the app, I consistently encounter an error message screen that reads: "You need to be on your home Wi-Fi and enter your admin password to proceed. Please ensure you're connected to your Wi-Fi and re-open the app and try again." I've attempted to connect to Wi-Fi using both the admin password on the hub and the one on the booster, but neither of them seems to work, leaving me stuck on this screen.

I'm hopeful that adding the boosters in the app will help ensure they reconnect automatically after power outages. If anyone has experienced a similar situation or has insights or suggestions regarding this issue, I would greatly appreciate your input. Thank you for your assistance in helping me address this ongoing challenge.