Pik Box Netflix Error tvq-pb-101

Reply
Highlighted
Friendly Neighbour
Since Sunday I am not able to watch anything on Netflix. I access Netflix app through my Pik box. I click on a show title and get the error "can not play title" with error code tvq-pb-101.

I have performed all troubleshooting: Unplugged and plugged my Telus box 3 times. Hard reset Telus box (pressed reset button on back). Rebooted wireless router. Switched HDMI cable. Uninstalled and reinstalled Netflix.

I contacted Netflix support. They tell me the following. If you already Restart your device and Troubleshoot your hardware connection. You may want to contact Telus to perform factory reset or upgrade your device to latest firmware. I understand that this may look Netflix issue but actually it is a problem with your device. Most of the time refreshing the device will resolve the issue.

Please let me know if anyone else is experiencing this issue. How do I factory reset if need be?
Highlighted
Community Power User
Community Power User

Netflix appears to be working fine for me on my PikTV box.

 

Have you tried reloading Netflix?

 

From the main screen in Netflix hit the Left arrow on the remote until the menu expands.

Go down and select Get Help

Go down and select Reload Netflix.

 

See if that helps.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Highlighted
Friendly Neighbour
Thanks for the reply. Yes I have reloaded Netflix as you suggested as per this troubleshooting: https://help.netflix.com/en/node/59709.
I have also logged out and and back in Netflx. I deleted the cache and data on Netflix app settings. I have uninstalled completely and reinstalled Netflix.

Do you know how to perform factory reset on Pik box.
Highlighted
Friendly Neighbour
I will also add that I can watch Netflix on my phone. Then if i cast the Netflix to the Pik box, it gives the same error on the tv instead big casting. I dont have a smart tv, so I have to use the pik box for my Netflix app.
Highlighted
Friendly Neighbour
...instead *of casting...
Highlighted
Friendly Neighbour
Hello again. I found the factory reset on the Pik box settings menu. This worked! Definitely something is buggy with my Pik box, I hope whatever may have occurred this week whether it was a firmware update or something else, doesn't reoccur.