OPTIK TV streaming issue at my work home

Reply
Highlighted
Resident

By accident, or by design, Telus has made it virtually impossible for me to stream my OPTIK TV at my work home

I have a second home in Alberta where I stay for work. I have hooked up Telus internet and security, but not OPTIK TV, because I am supposed to be able to stream it anywhere, including at my work home. But I can't access the login pages while connected to my Telus internet, so I disconnect and use my mobile hotspot, (also Telus) login in, and reconnect to Wi-Fi and then I can stream, until I change sources or the screen saver comes on. Then I have to do the whole thing again.

The last time I forced it like that the entire wireless system crashed for my house and I couldn't log back on to the Wi-Fi at all on any of my devices. Even hard reset with the reset button wouldn't work. I ended up leaving it unplugged for 24 hours and it worked after that.

I've called tech support multiple times and their only suggestion is a new box. 

Any thoughts/suggestions, besides switching my ISP to Shaw?

 

Highlighted
Ambassador

Can you elaborate on what you are doing to access the login page? What browser, device, errors? Need more information as this seems unusual.

 

Highlighted
Resident

Good evening

I did have a service call for a tech to come and replace the box, but they went to the wrong house and then Covid hit

I don't watch much TV during the summer months so it hasn't really been much of a concern.

I have tried everything. I've been dealing with this issue since December

Using the Crave APP on my Smart (Roku) TV -

  • Every single time I access the app I have to relog in 
  • I go to crave.ca/roku and login through my service provider (Telus)
  • Whether I use the My Telus Account or the older Optik TV account I get the same thing. The page refuses to load using my at home wireless
    • I have tried through my laptop computer using Chrome & Edge
    • I have tried through Chrome and Safari on multiple iPhones
  • I am able to connect virtually instantly and activate the APP through my cellular data

Using my laptop & desktop computers, Chrome, Safari, Edge

  • watchoptiktv webpage
  • I am not able to login without disconnecting from my home Wi-Fi and using my mobile hotspot on my phone - the login screen refuses to load
  • Once I login I am able to reconnect to my home Wi-Fi and watch normally, for a single use, must re-login 

On my iPad and iPhones the Telus Optik TV app works without issue on the home Wi-Fi

 

  

Highlighted
Ambassador

Any way you could try a wired connection to see if that works?

 

What kind of speeds are you seeing on your wireless? You can use this site to test:

 

https://www.speedtest.net/