Slow Gigabit Connection on TELUS PureFibre

Reply
Lotusland
Neighbour
Is anyone having a slow Gigabit connection on TELUS PureFibre?

I recently upgraded from PureFibre Internet 300/300 to a Gigabit, and am not getting anywhere close to the upto 950//750 as advertised. This is thru a hardwired connection to the modem directly from my PC. I am getting roughly 350 mbps down and 700 up via the TELUS Speedtest website. However I’m getting better results via the Fast.com website with sometimes hitting 800+ mbps down and 700 mbps up. Which of these are true? Telus PureFibre Technical Support told me that their back office informed them that they do not have the servers in place to accurately test the Gigabit connection. After troubleshooting the connection with them, they had me run download tests on 3 of my devices simultaneously, and concluded that I was averaging 300+ mbps down on each, and that I was indeed getting around the Gigabit speed. Is this correct? Any insight on this?
Community Power User
Community Power User

Gigabit has such a small installed base continent-wide, that testing tools and content delivery systems are lacking. Since the purpose of Gigabit speeds are to address multiple users on a single connection, rather than a single user getting Gigabit speeds from one site, I would suggest the info you have received s indeed accurate.

 

NFtoBC
If you find a post useful, please give the author a "Like"
CraigsWorld
Neighbour

I also just switched from Telus Fibre 150/150 to a Gigabit plan.

 

I find that I do indeed receive the 900 Mbps download speeds but only around 300 Mbps upload speed, the first couple of days it was 750+ Mbps.  This applies only to my tests done on a hardwired ethernet connection.

 

I get no where near these speeds through wifi.  I have tried with my iPhone 7, iPad (Gen 4) and a laptop that when hardwired get the full speeds but through wifi only around 300 Mbps for both download/upload. This the maximum speeds when in close proximity of the modem... move away 10-20 feet, the totals drop significantly.

 

I think the plan my be misleading.

 

I also wonder if there is a setting that is blocking the additional speed through wifi?

 

CraigsWorld

xray
All-Star
The Gigabit speed rating of the plan is for the connection from the router to the Internet. It has nothing to do with the speed of your WiFi connection between your device and the router. It has nothing to do with the speed of the Internet connection of whatever server you are connected to.

When you run speed test the results will show you the speed of the slowest part of the entire round trip, be it between the device and the router, between the router and the Internet or between the Internet and the server.

The fact that you get good results over Ethernet vs WiFi should tell you that your WiFi is the slowest part being measured.
CraigsWorld
Neighbour

How many Mbps is the T3200M capable of outputting? Looks like around 300 Mbps.

xray
All-Star

From the Actiontec web site:

Support for dual band 4x4 802.11ac (5GHz) and 3x3 802.11n (2.4GHz) delivers ultra-fast wireless speeds up to 2.3 Gbps*.

 

That is the theoretical speed assuming you have the right network adapter on your device and you are on a deserted island with no other signals. In the real world nobody gets close to that. For most people the limiting factor is the network adapter on the device and how many other WiFi signals are competing with yours. Looks like that's the case for you with the iPhone 7 which has a rated max of 450 Mbps and is likely being degraded down to 300 Mbps due to environmental factors.

Lotusland
Neighbour
Is Fast.com a more accurate tool to use?

Can you tell me if the download speeds are also hardware dependent, meaning in terms of the type and speed of the computer processor, amount of RAM and hard drive type. I am doing the testing hardwired to ethernet via a gigabit capable nic

Thanks!
CraigsWorld
Neighbour

I just used fast.com for the first time (usually either the Telus or Shaw - Ookla) and received 1.2 Gbps download speed but upload speed was only 220 Mbps.

 

I don't think it is hardware dependent (maybe for the NIC card). I get the same result with both of my desktop systems with I7 processors and lots of ram. My office laptops also get the same speed via Ethernet but are both I5's with a smaller amount of ram. They are noticeably slower than my home desktop computers.

Lotusland
Neighbour
Do you get the same results using Telus Ookla Speedtest, like 900-950 mbps down?
Lotusland
Neighbour
An update. I acquired another PC with an Intel i7 processor, and 16GB RAM, SSD HDD, etc. and now I’m getting the correct speeds via the Telus Ookla Speedtest and Fast.com. They are reporting consistent high Internet speeds, 950/750+, so the readings both down & up are in spec. The reason why I was having an issue initially was because I was running the speedtests on an older PC.
CraigsWorld
Neighbour

Yes, same results but only connected to Ethernet... wifi is a lot less.