Showing results for 
Show  only  | Search instead for 
Did you mean: 

How come I have to run a speed test to unlock gigabit


See above. My connection consistently throttles to kilobytes until I run Telus' speed test. After, and ONLY after, I run that, my speed goes to the rated speed where it will stay for the next five or ten minutes before dropping off again.

I found this out while trying to upload a YouTube video a while back and it has consistently been the case. I feel bad for people who bought gigabit but only get it when they run a Telus speed test but get silently throttled every other time.

Community Power User
Community Power User

Which wireless router are you using? What happens if you try uploading from a computer connected to ethernet?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I doubt running a Telus speed test and getting uncapped bandwidth so Telus can point to the speed test and say I am getting rated speed has anything to do with what hardware I am using. This is just pure shady. It appears to be at the service level.

The same throttling occurs when using my mobile for uploads through both the included telus router as well as downstream through a very nice GT-AX11000.

It will also occur on PC with hardwire. Heeeere we go again. From x kbps to 20 Megs