Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus email accounts not working on new MacBook Air



I have a new MacBook Air [Sonoma 14.2.1] on which I am not having much luck accessing emails using Mac Mail. I also have a desktop iMac on which I am accessing my Telus accounts just fine. I have two Telus accounts.

After signing up the new internet accounts on the MBA [with the GMail IMAP and STMP settings] the accounts show up in the Mail app but with a triangle ! icon. The mailboxes are empty.

The accounts on my iMac Mac Mail are working fine.

I have tried multiple times [adding and deleting the accounts] to no avail.

Any insights would be much appreciated.



Community Power User
Community Power User

When you added the account to Mail, did you manually add it or did you choose to add it as a Gmail account?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂


I added the accounts multiple times both ways. I should hasten to add that I also have other accounts [GMail and iCloud] on the MBA that work just fine.

Community Power User
Community Power User

I suspect it's related to Gmail changing access for 3rd party mail clients. You may find this useful:


Less secure apps & your Google Account - Google Account Help


Just a long time customer hoping to help.

I'm not sure that is the issue since I can access the Telus accounts on both my iMac and my iPhone. Furthermore I get alert messages on these accounts on my iMac and iPhone that a new sign-in was noticed on a Mac device.

Community Power User
Community Power User

I had no issues setting up Telus email on my new iPhone or my old Windows desktop. I had to set up an App password in Gmail when I setup Outlook on my new Windows desktop in order to get it to work.

Just a long time customer hoping to help.


I too have had no issues on my other devices, just the new MacBook Air. Looks like I may have to book an appointment at the Apple Store Genius Bar.

Same problem with my new MacBook Air and trying to set up Mail. I just spent 4 hours with Apple support  on phone and then 2 hours with the people at the Apple store.   Problem was not solved and in the end the APPLE Techs just gave ups and admitted defeat. Telus was of no help.


I am in the same situation, and I'm fairly certain this is an Apple Mail issue. The Mail app in Sonoma does not provide an option to set the "Less Secure Authentication" setting, as far as I can tell. I also tested this with the Outlook and Thunderbird clients for Mac, and neither one had any trouble setting up the connection automatically - no intervention, no tweaking.

Also submitted a bug report to Apple, but I'm not holding my breath !



Forgot to mention - I'm on a MacBook Pro M3 Pro. For what it's worth, my iPhone SE had no trouble (migrated from iPhone 8 about 6 months back), while my wife's iPhone 14 Plus fails and so does her 3 year old MacBook Air (also running Sonoma). The Air has never previously used the Mail app - only tried after I ran into the problem with my MacBook Pro.


I have also posted this issue on other forums [Apple, Mac Forums, MacRumors, etc.] to no avail. This is the only forum with anyone else understanding or facing the same issue. I'll try the Apple Genius Bar but am having to go through a gauntlet of queries.

I tried the "Less Secure Apps" setting, but 1) it did not make a difference and 2) I don't believe it is the issue, because Apple Mail had no trouble setting up my Gmail account, only the Telus account has a problem. Thunderbird actually reveals the settings it's using, which match the settings Telus provides in their documentation, while Mail is trying to connect on Port 0 (instead of 465 or some such port). It may be possible to work around by editing the preferences file, but, IMHO, it's not worth the effort.

Thunderbird and Outlook are both free clients, available from the App Store, and work "out of the box", so why bother ?




Hi Chris. (and others)


I ran into the same problem. MacOS Sonoma and Apple Mail.  Here is what worked for me, and should for you.


Definitely use the documented TELUS procedures to tell Google I want to use "less secure access" to the email.




Open the Apple Mail app, select Add Account and then DO NOT choose Google on the next prompt. 


Instead, select "Other Mail Account". 


Fill in the Email Address as your TELUS email address, Password as your TELUS email password. 


Click on Sign In. 


After a long wait, the access will fail, but you then have the option to change the email server.


Change to smtp dot telus dot net to smtp dot gmail dot com




Change imap dot telus dot net to  imap dot gmail dot com


Give that a try. 


Your new inbox will be named TELUS, but you then have the option to rename it to whatever makes sense to you.  


Give that a whirl and report back here so others can benefit.



Hello Mainframe,


Tested, and it does work. I already had the "Less secure Apps" setting turned on, and did reset the server names, but I think what I was missing was the "dot com" at the end of the gmail servers, and had left them at ".net".


Will need to try this on my wife's iPhone as well. We shall see.






Hi Mainframe, Fredp, et al;

I've tried the above previously, and once more just now [insanely expecting different results] but to no avail on my MacBook Air [Sonoma 14.2.1].

Bear in mind that the these accounts are, and have been, working on my iPhone [iOS 17.1.2] and my iMac [Sonoma 14.1.1].

Well, my test on the iPhone 14 Plus did not connect, but on the Macbook Air (Sonoma 14.2.1) it worked. On the iPhone, it kept telling me it needed a password, although I had already provided one. So that one still needs some research, but everything else is working now.

Not sure what Google is referring to as "Less secure", but it surprises me that Apple's client is considered "Less Secure" 😀. Also still find it odd that Mail had no trouble setting up my Gmail account, but then required all this tweaking to get the Telus mail to work.

Ok, I got it working on the iPhone 14 Plus as well. Here's what I found - on the Account page in Mail settings, touch SMTP, then the entry. Here -


Server - toggle OFF

Actually enter the user name and password, including the domain

Toggle Use SSL ON

Touch Done

It verifies your entries and ticks them off as it goes.

Back on the Account page, under "Incoming Mail Server", ensure user name and password are entered, again including the "" domain for the user name.

When you then touch "Done", it verifies the values and ticks off the entries as it goes.


Once all this was done, I went back into the Mail app, and Voila! it connected and is working fine now.


Hopefully, this helps you.

Sometime around mid February this year, while I was away on vacation, all three of my email addresses failed to sync any more on my Mac Mini M1 running MacOS Sonoma 14.2.1. All three are offline.  Has anyone else experienced this?

Community Manager
Community Manager

Not here, no. If you ever want to speak with our Tech Support team about this, they're available at 1-888-811-2323 or via Live Chat online over at and they can take a look with you.