Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can’t re-install Doorbell camera

A few weeks ago we noticed our slimline doorbell camera was no longer recording motion. Tried a few things on the app, tried to reset it even and nothing worked. Next try was to delete the camera and reinstall- well now weeks later and we still can’t get it added! I can make it to the step where you pick the Skybell wifi, and the put your own wifi password in… and then nothing.. install has failed every single time.. my wifi continued to work on a laptop and tv - but now wondering if not strong enough? Getting seriously annoyed with no working doorbell camera for security, and it flashing red non-stop…

Community Power User
Community Power User

Make sure you are connecting to a 2.4Ghz network it will not work on 5Ghz.

Yes it’s showing the lower network.

You will need to enter the Admin interface of your router, and temporarily turn off the two 5 GHz radios, add your doorbell while only the 2.4 GHz radio is on, then restart the 5 GFHZ radios.



If you find a post useful, please give the author a "Kudo"

This sounds like good advice. My doorbell has been unable to connect since last May. I have 2 booster units. Do I have to shut off the 5 GHz radios on both of them or will one unit pick up the doorbell when the 5 GHz is off?

Also, not seeing an "off" option. Only choices of bandwidth and channels.

I ended up using a different network in my home that was from an old Apple router that broadcasts the 2.4 and 5 channels separately, with different names. Worked great. Thank You NFtoBC

I've done that and still won't connect... Runs for a few minutes and then says installation failed. Do I need to wait a certain amount of time after we switch it to 2.4? 

I have no issue with mine on a 5GHz network.skybell.jpg


Friendly Neighbour

You don't need to turn the 5ghz signals off. 


Try doing a full reset on the doorbell. Press and hold it until it blinks yellow. Will take about a minute. 

Doesn’t ever blink yellow, blinks orange non stop. We were able to add a 2.4 network, but when we go through install (flashing red/green), sometimes the sky bell wifi connects and other times it says no internet connection and goes to Lite..
when it does work, it either freezes the Telus app or it still says installation failed after a few minutes
At a loss at how difficult this is given was the easiest install a year ago.. it’s about to be ripped out of the wall lol
Anyone else have this issue and finally found a fix? About to cancel Telus at this waste of money….