Showing results for 
Show  only  | Search instead for 
Did you mean: 

Optic TV+ app error Required output protections are not active

Friendly Neighbour

I used the previous version all the time on my Samsung tablet. Since the new updated version I cannot play any TV from the Guide. I either get this error "Required output protections are not active" or it hangs. I cannot find any explanation or workaround on your sites. I updated the app today. Is there any workaround? Can I no longer use your app from this device? It works on my phone. Anyway to get the old version back?


I get the same message. I have a Samsung Tablet and the Optik tv app worked. The new one does not.

TELUS Employee
TELUS Employee

Hi @Alberss @Dococ @Harrisclh 


Thanks for the details - I have passed it along to the app development team for investigation.

Friendly Neighbour

Hi @KHR @Dococ @Harrisclh

Here is my Update.

I created Ticket 4321055 on 2Dec. I was told I would get a call back in a couple days. Called Dec 6 and a different Telus person created another Ticket for a "Request to the back office". He promised he would call back in a couple days. Nothing. I called today Dec 15th. There is a note from Dec 8. Try same steps with clearing cache, etc. & reinstalling. If doesn't work I'm to contact Samsung. 

I guess I will wait for the next upgrade & keep my fingers crossed I will be able to watch again using the app on my tablet. 

All the best,


Helpful Neighbour
Arg. Thanks for the update

Just Moved In

I have the same problem on my Samsung tablet. I live how Telus says to contact Samsung because the Telus app doesn't work.


I just want to watch a hockey game while I make dinner.


I just installed an app to check my DRM settings. Both my phone and tablet have only Level 1, yet my phone can stream channels but the tablet can't.

Interesting. I was initially wondering about this. Decided to wait to verify if Telus requested when they called back. Crickets. Thanks for checking.

TELUS Employee
TELUS Employee

Hi @Alberss @Harrisclh @Susanpeyton @Bob_Unlikely @Hockeydad16k @Chester14 did anyone manage to resolve the issue? Our development team has been trying to reproduce this error, but unfortunately it seems to only be happening on specific tablets, particularly with an older OS version, and so far we've had no luck in reproducing this error with the devices we have on hand. 


If you are still experiencing this issue and is willing to share a bug report, it would go a long way to improving the handling of this error. Please see instructions below: 


Please provide a few details about your tablet:
  • brand and model
  • OS version and build version (on your tablet, Settings > About device > Software version OR Android version, varies per tablet)
  • TTV+ app (inside TTV+ > Settings > App information > Build version, please make sure you're on the latest build available from the Play Store)
Please also help us understand this error and when it occurs:
  • Does this error occur on both live and VOD, or only live?
  • Please provide the name of a few live programs (and their channels) that you tried and whether they gave the error or not
  • Same for VOD, provide a few names and whether they gave the error or not
Please enable Developer Options on your tablet:

  • on your tablet, go to Settings > About device
Then please capture a bug report
  • In the TTV+ app, try to play something that gives you the error
  • then immediately go to the tablet Settings > Developer Options and tap on Bug Report
  • You may be prompted to choose the type of report. Choose interactive if you can.
  • After 1-5 minutes you should see a message that the bug report is ready (it may appear only in the pull down notification menu)
  • Tap on the "report ready" message and share it (the best option would be to upload to Google Drive and share it to anyone who has the link, and then send the link to us so we can download it)
  • Full explanation


Thank you in advance!

Here is the link from Google drive

Colin Harris

On Feb 14, 2023, at 7:13 AM, Colin Harris <> wrote:

I have no resolve to this issue… I have created a bug report and will send it to you.

To answer the questions in your email…

Galaxy Tab S3
Model SM-T820
Android version 9
Build Number PPR1.180610.011.T820XXU3CTD5
I am on the latest build version available

This occurs on both live and VOD. Every channel I try on the live guide results in the same error Channel 104 (Global TV) was the one I tried this morning but every single channel has the same result. I tried both an episode from a series and a movie on VOD and both result in the same error.


Colin Harris

Thank you @Harrisclh, I've passed this information to our development team and they will review it internally. I will share any feedback as soon as I receive them. Thank you again! 

Friendly Neighbour

It happens with any content on the Telus TV+ app on my Samsung tablet. Nothing will play. Any chanel live, and any on demand content.

Samsung Galaxy Tab S3 SM-T820 OS9  One UI version 1.1

Build Number PPR1.180610.011.T820XXU3CTD5

Telus TV+ App Version


But Report: