Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus rewards poor user experience


I tried to redeem rewards. There's no menu option for rewards, I have to search for it in the MyTelus section. It's not even in the sub menu for MyTelus.


I redeemed for a $50 starbucks gift card. the email arrived instantly and the link didn't work. It says:

"Your eGift cannot be viewed at this time

We’re sorry. Due to a change in the card status, this card information cannot be displayed. This can happen if the card was replaced, canceled or expired. If you are unaware of your card status change, please contact customer service."


The email says to contact Starbucks and after a half hour and 3 transfers they weren't able to help me. They needed my starbucks card number, but the email didn't have one.

I decided to call telus (no phone number in the email) and I said "my rewards" to the automation. it asked for home or mobility. I have both home and mobility and earn points from both of them. they are pooled together and I redeemed them. So not really one account or the other, but I guessed mobility and after an hour they called me back and told me they don’t have access to my rewards so it must be for home services. I don’t know how I was supposed to know. They transferred me and the home services rewards person couldn’t see my recent purchase. They said it’s a week long process to get them to see it. They’ve reached out to the my rewards support team and will get back to me today. It’s been over an hour of calling around trying to get the reward which should be a simple process. There should be links on the website and in the email to take me to my rewards section and have a contact process. The email should say if the link doesn’t work then to contact telus, not starbucks.


Community Manager
Community Manager

Very sorry about this experience. I checked with our Rewards team and they mentioned that they're definitely aware of the Starbucks issue and a fix for the card redemption issue should be in place within a day or so. Did our team get back to you as you mentioned?

Yes they did get back to me, thanks! my reason for posting was more all of the user issues i.e. incorrect info on who to contact, no contact for rewards in the email, general number asks if my rewards are mobility or home when they're clearly grouped, no easy way to navigate to rewards section of website, no contact for rewards from the rewards homepage


@mechmanrick wrote:

I tried to redeem rewards. There's no menu option for rewards, I have to search for it in the MyTelus section. It's not even in the sub menu for MyTelus.


I found the link to TELUS Rewards under my Home Services section of the Overview page. I'm not sure where it would show up if you only have Mobility. Perhaps it shows up under the first service you linked to your My TELUS account which for me is Home Services.



Thanks xray,
I think I had mobility first, but the rewards is under my home services which is at the bottom of the My Telus/overview page as you've shown. Seems odd it could be mobile or home since they both earn points and can be spent just the same.