Windows 10 Xbox app server blocked

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Djaymo
Organizer

ok. so this has been driving me nuts for a few days now. I usually game on my xbox and PC. now ive never used a game from the MS store with the xbox app on the pc so i never had issues. But i been trying to play through the app this week and cant play with any of my friends.I tried all the xbox support solutions that are computer based issues and no luck solving my problem same with the 100s of google searches that range from removing adapters in the device manager to syncing date a time on the pc lol. so i go to check the network settings on the app and get this. 

 

xboxapp.jpg

Now the app runs pretty much like an xbox and uses the same stuff while gaming online so you can do crossplay etc so when i game on my xbox i have that running on a static ip and portforwarded accordingly on the router. so i have no issues there. I also have my PC on a static ip but that didnt help. and i cant portforward the same ports on my pc too the router wont let me because my xbox is using them. Ive tried using a DMZ as well and no luck. I have to think its router issue though because i checked my other pc and my laptop network settings and get the same "server blocked" issue.I am at my witts end with this and cant figure it out and was hoping some other telus users were having similar issues anyone? lol oh and im using the  Actiontec T3200M modem/router. anyways any help would be appreciated because im lost AF right now.

Community Power User
Community Power User

It was working fine for me until very recently when a big Windows update came in. I also get Blocked now also. I'm leaning towards this being a Microsoft issue again.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
jdowsett
Advocate

Open up a command prompt as admin and type netsh interface teredo set state type=enterpriseclient .  Should only have to do to it once - if you are a Windows insider you may need to do it after ever new flight (version).   Also I would move away from static IPs and goto reserved IPs handed out from the router and then may sure UPnP is turned on.   I keep my action tech firewall at low - but you can experiment - you at least want a Moderate Nat - Open preferably when you do the test.

Djaymo
Organizer

if i keep the router firewall set to low does that take the password authentication away when joining the wifi? 

jdowsett
Advocate

Nope just the level of inspection and blocking some known exploitable services.  Low is NAT only.  WIFI password is independent of firewall setting.

Community Power User
Community Power User

On the Actiontec 'Low' and 'NAT Only' are two different settings.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Highlighted
Djaymo
Organizer

which is better for less blocking?

jdowsett
Advocate

Sorry I was thinking of old Telus routers that had more options , NightHawk is right - pick NAT only for least blocking for your tests.

Djaymo
Organizer

ahhh ok, yeah i been using NAT  only for a long time so i guess that wont help.

Djaymo
Organizer

i was thinking today, would a DMZ help at all?

Djaymo
Organizer

@jdowsett wrote:

Open up a command prompt as admin and type netsh interface teredo set state type=enterpriseclient .  Should only have to do to it once - if you are a Windows insider you may need to do it after ever new flight (version).   Also I would move away from static IPs and goto reserved IPs handed out from the router and then may sure UPnP is turned on.   I keep my action tech firewall at low - but you can experiment - you at least want a Moderate Nat - Open preferably when you do the test.


I will say tho thank you for this command, its stopped the teredo from resetting everytime i start my pc. and having to restart it through the cmd. it always says "open now" unfortunately the server connectivity still says "Blocked" 

jdowsett
Advocate

Since I have two internet connections I was not experiencing exactly what you were - I now see your exact same when on Actiontec.   I will try some stuff and get back to you.

 

Just to be clear you are trying to achieve Xbox One and PC on same Actiontec router to have xbox live tests show Open Nat and no blocking messages?

 

Is that right?

Djaymo
Organizer

not exactly? I have an xbox one. which i use. through ethernet. on the same modem/router, but im just trying to play xbox PC games. like normal. the xbox is not connected when im using my PC. but the PC xbox app uses xbox live to be able to play with your friends etc. the problem is, for whatever reason i cant play with my friends while on the pc app. and i get that Server blocked issue in the xbox network settings. ive tried all the solutions that xbox support has and nothing has worked and i spent hours on google looking for others that dont work either. but essentially yes. i need to get rid of that server "blocked" message. 

Syaoran
Rockstar

I am a Windows Insider and don't currently have any issues with this.  My XBOX One X is wired through an 8-port gigabit switch that is connected to my modem.  My PC is wired directly into the modem.  I don't have Telus internet though.  Unfortunately, I am suck with Rogers when I am in Toronto.  Do you have the necessary ports forwarded for XBOX LIve set in your modem?  

Djaymo
Organizer

i do for my xbox. but my pc no. because they are being used by the xbox.  the modem wont let you forward the same ports on more than 1 device.I am also hardwired on both devices. im not a windows insider, is the windows version ahead of the public one?

Syaoran
Rockstar

For some Insiders, we are running an alpha of the next major build coming in the fall.  My other desktop though, which I also game on, is running the 2018 Spring Update.  When you port forward ports, don't just forward ports for one device.  You want to port forward the ports for XBOX Live for everything connected to your network.  You should be able to set a wildcard to gain an IP range for the port forward.  

Community Power User
Community Power User

I don't think it's something as simple as that. I don't have an Xbox and the server status on PC shows Blocked for me also. Ports aleady forwarded. Microsoft uses an IPSec connection to test the connection to their QoS server. I wonder if something is blocking that. Only IPSec settings I can find are under IPv6 on the T3200 and that doesn't resolve the issue.

 

https://support.xbox.com/en-US/xbox-on-windows/social/server-connectivity-xbox-app-displays-blocked


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Djaymo
Organizer

@Nighthawk wrote:

I don't think it's something as simple as that. I don't have an Xbox and the server status on PC shows Blocked for me also. Ports aleady forwarded. Microsoft uses an IPSec connection to test the connection to their QoS server. I wonder if something is blocking that. Only IPSec settings I can find are under IPv6 on the T3200 and that doesn't resolve the issue.

 

https://support.xbox.com/en-US/xbox-on-windows/social/server-connectivity-xbox-app-displays-blocked


ive done all this. plus a crap ton more from google search and nothing has fixed it.

jdowsett
Advocate

Hi there,

 

I did a chat with an xbox ambassador that pretty well summed up MS broke something.  Somehow my saved chat did not email to me however I have found more than one of these popping up.

 

https://answers.microsoft.com/en-us/windows/forum/games_windows_10/server-connectivity-is-blocked-fo...

 

Looks like its not "US" its MS and they know.  Technically with UPnP on most routers you should not even have to forward ports - and if you have more than one device you should not forward ports as that really only works for one device and the rest may end up not connecting properly. 

 

Since I have read people with the latest public Win 10 build and insiders on R5 having the same issue its probably on Xbox Live servers themselves.  Looks like a hurry up and wait situation...I'm going to stop banging my head - will report back when I see it working again!

Djaymo
Organizer

yeah im seeing ppl complain about it all over. still sucks though because i cant play with my friends at all. i can play games just fine. but i cant join parties or do any coop stuff.