Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to log in to government services website through home network & Windows PC


Is anyone else having this issue?  I can log in with an iPad on wifi and with the Windows laptop over my phone’s hotspot.  But through my Telus home network, I get connection reset errors.  One banking website also doesn’t function through the laptop, but the device apps are fine on the home network. Just trying to figure out where the problem is, but I THINK it’s with Telus and my laptop. 


Community Power User
Community Power User

What is the address of the websites you are trying to access? That information would be helpful in diagnosing problems.


How long has the laptop been unable to access the sites?

If you try to access the same websites (not the app) on the iPad, will they load properly?

Is the laptop just connected through wifi or have you tried connecting the laptop to the ethernet on the Telus router?

Do you have any other PCs in the house that have the same issue?

Have you rebooted the Telus modem/router/gateway?

Are you using just the Telus provided hardware or are you using your own router?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

The website was Revenue Canada’s sign in pages.  And some links at a banking website also wouldn’t work.  The boxes to enter sign in information showed correctly, then would change to a message saying online banking was unavailable. 
The laptop had no issues accessing these sites approximately 4 weeks ago, when I was at another location on a different network with a different internet service provider.  
The websites work correctly if I connect the laptop to my smartphone’s hotspot (Telus is also my cell service provider.)
The websites work correctly on the Safari browser on an iPad.  
I haven’t tried an ethernet connection yet. 
I have not reboot the Telus equipment yet.  
My hardware is all Telus. 

Thank you.  My time to work on this has been limited.  Thank you for your response. 



Community Power User
Community Power User

Possibly try a different web browser?

Just a long time customer hoping to help.

I tried 3 different browsers.  

Community Power User
Community Power User

I would recommend just rebooting the Telus router in your home as the next step. Easiest is just to unplug it for 10 seconds and then plug it back in.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Yes, I’ll give that a shot, when no one needs any tv.  I did take the laptops out to the garage (where Telus, for customer convenience, installed the router) and tried the laptop on ethernet.  No change. 

"home network & Windows PC"


Have you tried clearing your browser cache or using Ctrl F5? And it's just two sites you mentioned, CRA and your bank? You can surf ALL other internet sites, including IP streaming?

Cleared the cache in the Edge browser. That made things worse with the CRA site, couldn’t load any page at all on that browser.
Another banking website works. Other secure sites work so far, but I haven’t logged out of certain sites (and I don’t dare now!). I was able to log into a streaming site on the laptop, but I don’t watch streaming video from it.

You seem to have a securities issue with your laptop, not a Telus network issue. Like your laptop is blacklisted and/or getting blacklisted. Could be due to something residing on your laptop that is doing bad things to visited sites. 

It looks that way….BUT I can log in with the laptop when the laptop is using my phone’s hotspot to get online. That’s what is so puzzling about this.

But then your phone's IP is the facing IP to that site. So through your home ISP public IP address you are having issue.


Maybe you could try releasing you Telus WAN IP address, not sure it will work, I have never tried it. Power outages sometimes gets you a new public IP address. In the router there is a setting to release it. Under STATUS 



Just tried that. No joy.

You said: "I can log in with an iPad on wifi - But through my Telus home network, I get connection reset errors."


Can you access those sites with your laptop via WiFi also? ie, can you visit the sites that you couldn't visit via ethernet.


Or did you mean your iPad on Cellular, not WiFi?