Telus Boost Network Connection Dropping on iPhone XR and MacBook Pro

Reply
ArneSalvesen
Resident

Apologies if this is dealt with elsewhere, but my issue is a bit specific as outlined in the subject.

 

My setup:

T3200M Modem with a WCB3000 Extender connected via coax.  The WCB3000 is used to get the signal to my Optik Box

2.4G Wifi disabled on both T3200M and WCB3000.

5G Wifi active on on both T3200M and WCB3000.  Same SSID on both.  Use this network for my tenants downstairs.

 

Added Boost earlier this summer.  First booster is connected to T3200M, second is in the living room.  Great signal.  Great speeds.

 

Recently however, my iPhone XR and my MacBook Pro keep dropping off the Boost network,  I try to reconnect but am told the password is wrong (iPhone) or it just won't connect (MacBook).  She can share the PW with me from her phone, and then I can connect. My wife's iPhone 6 has no issues (nor her Windows based PC). 

 

If I reset the Boost station in the living room I can connect again for a short time, but then the problem re-appears.

 

I've tried switching the boosters with no affect.  

 

I am at the end of my technical knowledge.  Any ideas?

rc
Ambassador

Telus recommends that the boost have their own unique ssid. 

ArneSalvesen
Resident

I've done that.  Boost is one name, and the 5G from the router is another.

epikish
Neighbour

Hi, I'm having this exact same issue. Did you manage to fix it? It only seems to happen on some Apple devices. I have no problems with connecting on my android phone, but my macbook and sister's iphone keeps getting disconnected.

botsauce
Resident

I have the same issue. The boost network worked fine for a bit, now my MacBook drops from the network and can't stay connected.

I'll update after I call tech support.

epikish
Neighbour

Any luck??