TELUS E-mail & Expired Certificates (Expired SSL Certificates separate from other e-mail issues)

Reply
DK-YYC
Neighbour

 I access TELUS e-mail via Outlook 2013 and I've made NO changes to settings of late in Outlook. This morning I received a message indicating that I had an invalid certificate. It said that there was an invalid SSL certificate error. The certificate reportedly expired on 2019-09-09 12:30:43 PDT.

 

What is interesting is that I've seen numerous other TELUS users in this forum (but mixed in with the general TELUS e-mail outage discussions) who have an invalid SSL certificate error with EXACTLY the same expiry date (the certificates were for five years).

 

What is the fix for this problem? I'm a bit apprehensive to start going into menus in Outlook that are recommended online, specifically:

File - Options - Trust Center - Trust Center Settings E-mail Security; specifically when Microsoft says, "The Trust Center contains security and privacy settings. These settings help keep your computer secure. We recommend that you do not change these settings".

 

Is a new certificate needed and if so, how does one get one? When you go through the Trust Center there doesn't seem to be an easy way to rectify this (and I'm a bit hesitant to given the warning from Microsoft). Why hasn't TELUS put up an article on this issue as is affecting multiple users?

FuzzyLogic
Connector

FWIW I'm seeing the same thing in Outlook 2016.

 

I was also prompted multiple times for credentials for Outlook today. It eventually sorted itself out. My credentials have not changed.

 

It would appear there are still issues with email services.

grateful1
Friendly Neighbour

I use Thunderbird and created an exception to the security certificate on Tuesday when the certificate expired but have no idea if that creates a security issue.

I echo your questions to Telus and could not find any answers on their website:

"Is a new certificate needed and if so, how does one get one? and What is the fix for this problem?"

If this issue is affecting many customers it would be more efficient to post the solutions to this (new security settings etc) rather than have every single customer called them individually to ask for the same information.

If anyone has received the answers to these questions could they please post them? Thanks.

DK-YYC
Neighbour

So it looks like the problem is in the process of getting solved (I only say process because my Outlook folders are currently re-downloading). This is related somewhat to the e-mail outage from last month. When TELUS did the e-mail server repair, it appears that some of the settings have changed in the IMAP settings, related to the Outgoing server SMTP settings and the Incoming mail server IMAP settings. We did have to try a couple of combinations of settings to get things to work. I obtained the solution - i.e. the correct settings - by calling the Technical Support line. 

My folders are still downloading so it might be a bit premature to say that all is fixed but things appear to be going okay. Thanks to Jay and Kyle on the Technical Support line who have provided assistance thus far.

romatt
Friendly Neighbour

I to am waiting for a Telus fix. Perhaps a tech support call is needed. I am hesitant to try other fixes as well. Hoping Telus will fix this. I can still get to my email by saying Yes, to the do you want to continue with this server. 

FuzzyLogic
Connector

I talked to Telus about this yesterday and they tried various things but ultimately were unable to resolve the issue.

 

I believe they need to update the certificate on the mail server(s) so that they present the updated certificate to the client when it connects.

 

In the mean time you need to accept the expired certificate to continue to use Outlook.

 

VlK6161
Resident

Go to File>Account Settings>Change>More Settings>Advanced> Use Defaults > OK > Next > Finish

 

 

For Outlook 2010 and 2013 

 

 

dejong
Resident

Hi

I entered Outlook and followed the steps described. Worked like a charm. It seems to reset and find the correct update Telus certificate. The messages about the "expired" telus certificate stopped.

Thanks

jrueger
Ambassador

Are you sure it has actually fixed the issue?  Reverting to defaults probably returns Outlook to an unencrypted connection which doesn't need a certificate.  That's not a fix.

Byte-Wyse
Friendly Neighbour

There is a similar discussion in another thread in these forums located here .  I was able to solve my problems by changing the ports used for incoming and outgoing email. You may have to do a little bit of trial and error depending on whether you are using imap or pop3 and also based on your specific client.

 

I was able to solve the error messages (for my pop3 client) using port 995 (incoming using SSL / TLS) and port 587 (outgoing using SSL / TSL).