2.4Ghz not working, or only working for a couple of minutes but then slow

Reply
awadiallo
Resident

I recently bought a Sonos speaker and therefore had to disable "SmartSteering" on my router (T3200M) so I get a 2.4Ghz Wifi.

Initially it didn't even show up (even thought SSID broadcast was enabled). I then eventually was able to connect my phone and computer to it, but it was incredibly slow (like 600kb slow). I disconnected my computer again and then it couldn't be found anymore. This processes repeated itself for several hours. Either it was not there, or if it was and I was able to connect then it was slow or not even working at all.

How can I get a proper and acceptable fast 2.4 wifi?

 

Also, I live in a 2BR apartment and the router is only 20-30 feet away from my computer/phone.

Community Power User
Community Power User

It was working with Smart Steering enabled?  Usually, as long as you have connected to the correct SSID, it should work just fine without Smart Steering enabled; after all, there is no change to the two radios, just how they are shared with your devices.

 

NFtoBC
If you find a post useful, please give the author a "Like"
awadiallo
Resident

My Wifi works fine with smart steering enabled. But then it switches between 5 GHz and 2.4 GHz and my speakers only support 2.4 GHz Wifi.

Therefore I have to disable smart steering and just use the 2.4 GHz connection.

 

However the 2.4GHz wifi is really sluggish. Sometimes it doesn't even show up, and when it does it is super slow or doesn't work at all.

 

I've rebooted the router, I've reset the router, so I'm not sure what else to do.

Any experience or suggestions on getting 2.4 GHz Wifi to work