Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot Access On TELUS Network

Neighbour is the OFFICIAL Hyundai website to connect to their cars.

It doesn't work in any device connected to my home wifi. But works just fine if I am connected to a VPN or in other networks like Shaw or on 4G (mobile).


Similar issue: 





I tried tracing on a Shaw network and it works just fine...



Community Power User
Community Power User

I am able to bring up that website without issue on my Telus connection using my wired Windows 10 desktop (Chrome), Windows 11 laptop (Edge, wi-fi), and on Firefox on my iPhone connected to my Telus home wifi. What message are you seeing when you try to access it from your wifi?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂



The website just doesn't load. I tried on my Windows 10 laptop, macbook and smartphone.



It is weird because if I use a VPN it loads just fine.


ping test:




I am experiencing the same issue

I had TELUS PureFibre installed last week. Ever since, I cannot access from a browser on my home network (Wi-Fi or wired), or use the app on my phone (while connected to my home Wi-Fi).

Pinging that same resolved address,, fails.

However, if I use a VPN service on devices (or mobile network on my phone), it works fine.

Did you ever find a resolution?

Unfortunately no 😕


Just a little bit of background. I was living in Edmonton downtown and didn't have purefibre (it was through old copper cables) when I had this problem.


Now I am living in Calgary and since I moved (still with telus), the mybluelink website works just fine.

There is fiber in my building, but the Telus modem that I am using is still the same (the only thing is that they had to do a hard reset to reconfigure the modem for fiber).


I believe there is something blocking the website in one of telus' network nodes or something like that... That probably just affects Edmonton or some areas of Edmonton


I would have little faith in getting anyone from telus support with enough knowledge to troubleshoot this, but maybe still worth a shot.