Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus TV Plus App/Website


I started using the Telus TV Plus app/website to stream live tv. It works 50% of the time only. When it doesn't work, it doesn't allow you to login/seems like their website is crashed.


Is anyone else having this problem or know a solution?



I click login and then have to click on the login a second time before my icon appears. was not always like this.

I see, when I click login on the website, it says "This site cannot be reached" and for the app, after I input credentials, it stays on the logo page.


I get that somtimes, just clicl login again, sometimes immediate, less often complete new sign in with password

Unfortunately it's not working. Is it working for you right now?


yes working 

TELUS Team Member
TELUS Team Member

Hi @dudees75, which browser are you using for the website and do you use Apple or Android for the app? 


Hi Kate,

I tried 3 browsers, Chrome, Firefox and Microsoft Edge and all 3 have connectivity problems. For the app, I am using Apple.

I'm not sure if it's my wifi thats creating the issue then because the TelusTV plus app/website legitimately only works 50% of the time.


Have you tried both 2.4GHz and 5GHz?

You can eliminate WiFi as an issue if you can connect directly to your router with an ethernet cable.

You may be experiencing a high level of packet loss somewhere.

There's a site that does packet loss tests at:

It's worth seeing if that's your issue.
If it shows packet loss, then you'll need to determine if the problem is your local WiFi or if the problem is upstream from there.