MyTelus Sign on Page Not Responding

Reply
Ricardoedm
Friendly Neighbour

 

 

So, I'm trying to sign on to MyTelus (yes, I clicked on the link from the Telus website to go to MyTelus) at

https://www.telus.com/en/mobility/content/my-telus?linktype=ge-mainnav

and end up with a page saying "Sorry This Page Has Expired"

and I get redirected to https://telusidentity.telus.com/as/6bxTu/resume/as/authorization.ping?service_type=telus

 

(I tried to upload the screen shot of the page I get but the upload was taking forever)

 

Anybody know why this happens or what it is?  It just sends me back to the LogIn page and repeat again...

 

 

 

 

 

 

xray
Guardian

I've seen that many times. You can reload the page (F5 in Windows) to see if that fixes it. If not then close the browser and start from the beginning again. If that doesn't fix it then you need to delete all the cookies for telus.com in your browser settings.

 

Ricardoedm
Friendly Neighbour

I was hesitant to do that because I worried it would count as the "5 incorrect tries then reset password" situation and it would lock my account.  I guess you mean a flush of the cache or reloading the page a few times without the sign-on info

 

Thanks for the suggestion, I will give it a try

xray
Guardian

You are not getting the error due to an invalid login so it won't count as an invalid attempt.

There is an old expired session cookie hanging around from a previous login that the web site isn't clearing properly for you new login and it's getting confused.

Ricardoedm
Friendly Neighbour

Thank you.  The reloading only didn't work and it even didn't work with another browser

I did a whole browsing history/cache clean for Chrome and that seems to have done the trick.  Thank you so much!