Showing results for 
Show  only  | Search instead for 
Did you mean: 

Account login

Just Moved In

Has anyone experienced login difficulties with account login.

Using the existing MyTelus   i  Verify Human  ( needs to review the security of your connection before proceeding.)  serval times then kicking you back to login again.

Then I go to log in a different way using email and that gives log in from your email. yes I registered..

Clicking on the login in email it churns for a few seconds and then asked if I want a new login attempt. After 3 attempts to log in  it shuts you down and says Go through this stupid attempt in 24 hrs.

Good luck talking to chat Bot.. they offer solution to log into your account which you can't log in in the first place.

Also talking to support in this phone company is non-existent . Last 5 attempts all 3 north American agents were busy.



Community Power User
Community Power User

I haven't seen this. Have you tried a different browser or the MyTelus app?

Just a long time customer hoping to help.


Yes, I've been having this same issue as well.  It  started in November and I phoned the 1-800 number and got a call-back.  They managed to get me logged on but wouldn't say what the issue was.  Had the same issue again in December but managed to connect on my work computer.  Now its January and I get the same error on both my home and work computers.  


Called the 1-888 number again and was able to log in while speaking to an agent.  They said they could not tell me why it was happening and wanted to put me on hold for tech support.  I requested another callback and they said it would be at 6:00 p.m.  I assumed they meant 6:00 p.m. my time but they tried to call back at 4:00 pm while I was out.  Tried to log in again and got the page not found error again.  Very frustrating and I still have no idea why this keeps happening.  I'm not impressed.