Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Add Call Control


I have had no success adding the Call Control feature. I’ve been with TELUS mobility for about a month now. When I try adding it, the website (or app) says “adding call control, check back again later”. But when I check back later, such as later in the day or the next day, the feature is not added. I have tried many times over the past 4 weeks to add this and the feature is never activated. I’ve tried this with both the My TELUS website and app. I phoned Support and got nowhere. (I don’t think they understood what Call Control is). Please help.


Community Power User
Community Power User

It sounds like you've done everything correctly.


Based on what you've said you will likely need to work with Telus to get this sorted out.

Just a long time customer hoping to help.

Thanks. I finally got this resolved. The support agent had to escalate the issue to the tech team. They found that the web interface was failing so there was no way I would be able to add Call Control (no kidding). So eventually they were able to add it at their end.

(One thing I found frustrating about this whole situation was that the automated support system assumes the customer simply does not know how to add Call Control, so it just wants to send you a link with instructions. It can be frustrating trying to get past this runaround in order to reach a live agent).

Thanks again