Showing results for 
Show  only  | Search instead for 
Did you mean: 

TelUs TV+


The New Telus TV+ APP I receive an error report and its says.

430-10146 Your rental has expired or this program is not included in your subscription. Please repurchase.

Can you tell me why this would be and I can't find anything in the site to get the answer 


Community Power User
Community Power User

Can you provide more details as to what program or channel and the phone you are using?


If you find a post useful, please give the author a "Kudo"

I believe that he means on his browser on his computer. At least that's the case with my exact same error. When using Chrome and following the instructions and browser requirements on the Telus site for viewing Telus TV+ on my computer I'm able to log in but none of my subscribed or playable at-home channels show in the guide and everything else is locked. Weird. 

Community Power User
Community Power User

Possibly try logging out and back into the app?

Just a long time customer hoping to help.


I'm getting the exact same error. Its as if when I log in it doesn't recognise my account. I can use the guide to see all the channels but when i go to my subscribed channels nothing shows up. This is after I logged in with my Telus home account.