Showing results for 
Show  only  | Search instead for 
Did you mean: 

Number Transfer

Just Moved In
Hi, my fiancée was with Bell and needed a new phone so I added her on my account and ordered a new IPhone 14. We received it today, and set it up, inserted new SIM and requested a phone number transfer. It usually takes 30mins to 2:30. It has been 10 hours. Chatted with some agents who said it’s a company wide issue with ports and we should get a text when it’s completed. However, it says on telus app that the transfer was completed. But we didn’t get a text and phone is still not connecting to Network. We reset the network settings, restarted the phone, re inserted the sim card etc.

Just checking to see if anyone else is going through this or if someone experienced this before. We will be contacting someone tomorrow if it’s still not fixed but was hoping to get some answers here maybe.


Community Power User
Community Power User

When you first set up the phone, you should have been issued a (temporary) Telus number, and the phone should have connected to the network from that number. The Telus number would have subsequently been displaced by the bell number.


What happens if you put her old SIM in the phone, or uses her old phone?

Did you provision the new SIM by adding it to the new account you created? Usually you need to add the SIM number in the account.



If you find a post useful, please give the author a "Kudo"