Showing results for 
Show  only  | Search instead for 
Did you mean: 

Port Forwarding and NH20A (Telus Internet Hub)


I got my equipment upgraded last week to include the new NH20A. Really nice piece of hardware. Get the install completed, so grab the admin credentials and get to work configuring it. Proper DDNS client, 10 Gbps port for my work machine, the whole shebang!
So imagine my surprise when I discover (through hours of testing, multiple support calls and another TELUS technician visit) that the advanced functions of the NH20A have been administratively disabled on consumer internet plans despite the relevant menus still being present in the GUI! You can add your settings; they just won't work!

When the on-site tech called HIS support, this is the summary of the conversation I had with them:

  • I can bridge the NH20A and use my own device for Port Forwarding (which means I lost the 10Gig and MoCA 2.5 ports; big deal in my house)
  • I can use my older T3200m instead and have it work as it did before.
  • The tech wasn't permitted (by policy; he'd 'get in trouble for turning it on') to enable Port Forwarding on the NH20A


What in the actual heck?



@TheCanadianShield Wrote: 

  • I can bridge the NH20A and use my own device for Port Forwarding (which means I lost the 10Gig and MoCA 2.5 ports; big deal in my house)

If you would be so kind to confirm that when you place NH20A in bridged mode that the 10Gbps port no longer functions as a 10Gbps port?


If this is indeed true, what speed are you able to connect at utilizing that port?


If you find this post useful, please give the author a "Solution", or mark as "Kudo", if it solves your problem, thank you very much.

When I say 'lose', the ports themselves still function, but from a NAT/port forwarding perspective, they're on the public side of the internet connection as opposed to being on the private side of my own device. Not helpful.
Where I'd like some help is understanding/rectifying why the port forwarding functions on the NH20A don't seem to be working as expected given the menus are present and the configuration is identical to my outgoing T3200.

@TheCanadianShield Wrote: Where I'd like some help is understanding/rectifying why the port forwarding functions on the NH20A.


Ok, got yeah.... The basis of the bridged mode is to remove any functions from the NH20A device, and allow a direct passthrough of the Telus signal.


Those of us that want to have our own dedicated networking devices this is the best way to accomplish the task.


I for one have a direct connected Telus connection to my Ubiquiti Unifi network consisting of a Unifi router device, a number of Unifi switches, and then wireless AP's and MoCa devices as required to cover my needs.


The setup requires more devices, and hence cost to the individual, however, I can manipulate, port forward, isolate my entire network to my hearts desire.


The NH20A is a great device if you want to only utilize basic functions, however, once you delve into the more structured network topology, you a correct that the internal functions may not accommodate what you may desire.


If you find this post useful, please give the author a "Solution", or mark as "Kudo", if it solves your problem, thank you very much.


I get that I can spend additional hundreds of dollars to increase network complexity to replicate the basic functionality that's already present (but not working) in my current network with the NH20A. 
What I'm looking for is clear, definitive guidance either on:

  • how to resolve the issue I'm encountering with port forwarding on the NH20A 
  • Some formal response on why the NH20A is the first telus gateway EVER to have port forwarding administratively disabled as a function.


Hi TheCanadianShield,


If you configured the LAN 10G port as the Bridge, then 10G port cannot be used as default function it had before.

I have similar configured at my house, the MoCA one still works normally. 


Unfortunately, not it either.
No bridging functions are enabled on the NH20A.


I use mine bridged, but if I were to use it as my firewall/router, I definately would expect basic things like port forwarding to work!


I'm at a loss to explain or understand why it's not working.
The frustrating thing is that the hardware itself is really good. Proper DDNS client, good UI, all the things most people would want, which makes something like this seem really glaring in comparison.

I'm experiencing the same issue but with Port Fordwarding not working despite making the configuration. I want to get my money's worth out of PureFibre 2.5 and Plex but any and every suggestion and instruction don't seem to work from the OS level for my Laptop to the Modem level with the NH20A. I did call Telus asking if they've done something on their end to restrict Port Forwarding to which he said yes but posting on reddit and seeing people reply saying they can Port Forward is frustrating.

So here's where I'm at. My Technicolor NAH (FXA5000) is working. 
How? Not entirely sure, but I believe it was an IPv4 firewall issue and not port forwarding that was the culprit. The issue that I was having (and I'll reiterate that this was MY experience) was that the port forward rules were valid and the specific ports themselves WERE open. What I determined was that the IPv4 firewall rule set would never completely set itself to NAT-ONLY. I tried bypassing the NAH, using my T3200M, bridging every single port. Heck, I even borrowed a UDM pro and dropped the GPON SFP into it. All of these worked as expected. The only thing that didn't was running traffic through the NAH in gateway mode where the ports I had forwarded would test as open, however, the traffic wouldn't be visible on the internal network (thank you wireshark). This brought me to concluding there was a firewall/traffic filtering issue at work.


My solution? I was able (through friends and people I used to work with) to get in contact with the team that does consumer device testing and pled my case, complete with documentation, Visio diagrams and my hypothesis. I never received a definitive answer, but I left the NAH live for a couple of days, performed a factory reset on the device, and everything worked as expected. I've never received any follow-up comms explaining what changed, if anything, but it does seem to work now.

Things I learned to get to the point where I could make my case:

- First, There are TWO different NAH's: The Arcadyan NH20A and the Technicolor FXA5000. Look identical, but different manufacturers and different UI's. This is important because the only people seeming to have issues have ones with Technicolor NAH's and not the Arcadyans. 

- Second, everything you've been told by people on the internet and front-line TELUS support (this INCLUDES installers) is at best, half-informed and at worst, flat-out wrong. Most people don't know there are multiple NAH's or they confuse the Boost WiFi 6 devices as the NAH or god knows what else. Bottom line: If they can't show their work, weight their perspective accordingly.

I have the Arcadyan NH20A and I even called Telus today to see if I can switch to a Business plan since that will get me remote access and a static IP address. So, you would recommend factory resetting my NAH? That could do the trick? I'm at my wits end with this issue.

I would give it a try. 
Full reset, then put in one of your PF rules immediately and see if it works. Don't change anything else.
If it doesn't, reset it again before going to bed (TELUS pushes their device FW updates overnight, try it in the morning and hit it again.

I'll give it a shot this weekend and keep you posted.