Showing results for 
Show  only  | Search instead for 
Did you mean: 

MyTelus Website not working!

Friendly Neighbour

For the last many months, the MyTelus website has not been working.

I can login OK and see my Overview just fine, but when I click on any of the tabs like Internet or Home Phone, etc., I always get this error message - "Looks like something went wrong! Please Try again."

And however many times I try, the same error keeps coming up!


I called Support and they tried to help me - I was asked to change my password, which I did and then the MyTelus seemed to work OK. 

But again today the same error keeps appearing.

As a result I cannot manage my section and this is getting WAY too frustrating!


I don't know what else to do and support does not seem to be able to help fix this issue.

Any suggestions anyone?


Community Power User
Community Power User

It very well could be the browser you are using. Which browser are you using and what version is it?


Have you tried the My Telus app for iOS or Android? If yes, does it have the same issue for you?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂