Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issues with Arcadian Wi-Fi Hub

Hey guy...been having a couple of odd issues with my Wi-Fi hub, and wondering if anyone has any suggestions.

1) I haven’t been able to run a speed test in the My Wi-Fi app for about a week.

2) I was trying to watching something on Crave on my iPhone today and the signal kept dropping. I know this because I was constantly getting a warning that I was using mobile data. This was happening whether or not I was moving. I have two Boost units in the house as well.

Tried restarting but it didn’t seem to help. Anyone else having issues?


Do you see anything unusual in the Arcadyan system log?

How do you get to the system log? I can't find a log in the web utility or in My Wifi.

Sorry, I don't have that router. I just assumed it would have access to the system log with the Admin login just like my T3200M.

Fair enough. The admin settings are much dumber in this one.

Yeah, so it seems and nobody can find a user manual either. Makes me think twice about getting Fiber when it becomes available in my neighborhood.

Just Moved In

I had this issue a couple weeks ago. I have 1.5gbs fibre and was getting speeds are 300mbs on wifi so I performed a manual factory reset on the wifi hub. After the reset, I could no longer perform a speed test through the telus wifi app as it said the device was offline. Spoke to a couple reps with no success and I had a tech come by but didn't do much to resolve the speed issues and the new issue of not being able to run a speed test.


The solution that worked for me and got everything back to normal was to sign into Mytelus and change my internet plan from 1.5gbs to 1gbs, then after 10min or so, switch my plan again back to 1.5gbs. Then I re-installed the telus wifi app, registered the wifi hub again, and ta-da! Just a theory and not certain if my little workaround actually did anything, but may be worth a shot!