cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Apple TV and PikTV - Login Failed

CozyBlanket
Just Moved In
Hi all!

I ordered an Apple TV from Telus as part of my PikTV package. I have downloaded the app and everything but I cannot login to the PikTV app itself. It keeps saying login failed even though the username and password are right. Everything else on the Apple TV works great, just not this app.

I can download the app on my phone and I have no issue logging in so I have no idea what the issue is.

Has anyone experienced this before?

And yes I've tried restarting the Apple TV, deleting the app, resetting the Apple TV to factory. I have even tried changing my password. We got the Apple TV specifically for the PikTV so this is beyond frustrating that it isn't working.
2 REPLIES 2

NFtoBC
Community Power User
Community Power User

@KHR 

Any suggestions for this instance where login to PikTV works on iPhone app but not Apple TV App?

 

NFtoBC
If you find a post useful, please give the author a "Like"

KHR
TELUS Employee
TELUS Employee

Have you tried either enabling or disabling the 'TV Provider' login on the Apple TV? You can access this via the Apple TV Settings, then Users and Accounts, then Apple TV Accounts, then TV Provider. You can allow/disallow a 'zero sign on' experience where the Apple TV recognizes your TELUS internet connection and logs you in automatically.