Showing results for 
Show  only  | Search instead for 
Did you mean: 

Setting the guide to your favorites only TelusTV-21T


I spent two hours with tech support and my options button only has All Channels

then I found this forum and the below pinned on how it is supposed to work

Then I spent another hour and half in a chat with tech support. A new box was sent out with the same results, unable to choose a guide with only the favorite channels.

Then I have been PM ing with Kate who is BTW trying to help. 

A known problem without solution it appears, but everyone is trying to help. Everyone agrees how it should be.


Anyone else having this issue?



Press the Guide and then the options button




 You can also use the Options” button to filter the guide to only show subscribed or favourite channels.


0 Kudos

Hi @sportsguy1 can you try logging out of the box and relog in? You can do so via: settings -> account information -> switch account -> log out

Let me know if it changes anything after you relog!

View solution in original post



What is the model number of the Optik box you have?

The newest one TelusTV-21T

Is this forum not just for that box?

The Optik service has moved to new Android cloud based boxes but many Optik subscribers are still on the old boxes. I'm still using the Arris VIP boxes. This forum is for all Optik users regardless of the hardware.

GREAT! This explains a lot. The new gen box is not the same yet the guidance is given as if it was the same.

No wonder tech support does not have the answer. Thanks

Community Power User
Community Power User

This forum is for Optik TV. Even though on the new set top boxes it says TelusTV+, they still refer to it as Optik. Gets confusing at times as both have different hardware, settings, features, etc. You've also already posted this in another discussion about the Options button as well.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks for pointing that out. However I started a new thread called Option Button and moderation thought it would be better buried among other things which I now wonder are new or old gen tuners. I also asked if I am the only one on this board with the telusTV-21T to have this problem, so far no replies. So I reposted in hopes it stands out from all the other issues with these TelusTV+ boxes.


Yeah, the transition to the new platform has caused a bit of confusion. Sometimes it's hard to tell if the issue is with regards to the old hardware or the new hardware based on the posts. It's not uncommon to see a new user to the forum who is a long time subscriber using the older boxes.


I heard there is a software update coming September 20th

TELUS Team Member
TELUS Team Member

Hi @Rocky3 I didn't realize you made a separate thread that's why I've been responding to you on the bulletin board. I will drop the same troubleshooting step I've shared with you in case anyone else is experiencing this and can use it as a reference. These troubleshooting step I'm providing is for the latest TelusTV-21T. 


You're also not alone in experiencing this; I found a couple of tickets with a similar issue with our support team. Unfortunately, none of the users got back to us on whether the troubleshooting steps worked, so it's still a mystery as to why this is happening on certain boxes. Thank you for your patience as we continue our investigation. 


1. See if you can force an update through settings -> Device setting -> apps -> TTV+-> Update (should be below force stop)

2. If that doesn't work, factory reset through settings -> Device Settings -> Device preference -> Factory Reset (all the way at the bottom) You would have to reset up your box if you select this option.

3. If none of it fixes the guide filter issue for you, we have another software update coming Sep 20th, and we're hoping that would fix the guide filter issue. 


I know you tried step #1, have you tried step #2 as well? Factoring reset? 

Yes I tried step 2 and no difference. Later or weekend I am going to repeat steps on both boxes. I still do not understand why after uninstalling updates, they were apparently reinstalled without asking or allowing me to press update. Maybe some extra steps like reboots.

Your instructions I can interpret, but are they the same layout as mine

1. See if you can force an update through settings -> Device setting -> apps -> TTV+-> Update (should be below force stop) I showed uninstall updates. Then system updates was under the Device Preferences>About. Each time I have clicked on check for updates it says I am up to date already.



This is what I see



I agree with Rocky that this is a real issue and I have followed same steps and same result.  The only option he shows in his pic is one that allows one filter option "All channels".  I made the mistake of choosing that option thinking maybe it would go to a sub-filter allowing me to customize it.  Nope my guide actually shows every possible channel available even the hundreds I am not subscribed to.  And even worse it will NOT allow me to deselect the option now!  So I am now stuck having to scroll through the expanded guide and accidentally hitting channels only to be told "go to MyTelus to subscribe to this station".  Really hope a complete reset and the new software update due September 20 can help or I'll need to return this box.

Hi @sportsguy1 can you try logging out of the box and relog in? You can do so via: settings -> account information -> switch account -> log out

Let me know if it changes anything after you relog!

Mine is now fixed. Did the log out log in. I am sure that in itself just applied the fix, but happy that it is resolved. Put a mark on the wall for a Telus success.