Showing results for 
Show  only  | Search instead for 
Did you mean: 

Having problems accessing my rewards page


Good morning.

After logging into MyTelus Home page, I clicked on "Go to your Rewards Account" link

On the resulting page, I clicked on the green "Access your Rewards" button

On the resulting page, titled Terms and Conditions, I click on the green "Accept" button and are continually presented with the Terms and conditions page again and again. Can't get by this.


Anyone else with this problem?



I just tried it. No problems getting in. I didn't get the terms and conditions page because I've logged on before so I must have already agreed to it in the past. Sometimes these terms and conditions forms require you to page all the way down to the bottom of the text to show that you viewed the entire document before you can agree.

Thanks for the response. I have also logged in before, and actually used points before. I also looked that the terms and conditions page, and scrolled to the bottom but the only buttons at the bottom was the "Did you find this helpful?"


I just tried it again and got the Terms and Conditions page. After accepting it took me to an error page.

I went back to my account and repeated and this time I got straight in to the rewards page.


Try this link after you log in to My TELUS and see if it makes any difference.

I don't know what happened to my post, but I'll try again.


After I logged into My Telus, I accessed my rewards by the link, them pasted that link you posted. The rewards page showed for a second with the fields not filled in, then I was presented with the Terms and conditions page.


The 4 links just above the Terms and conditions (ie Dashboard, Catalogue, etc do nothing, but the 5th link and the FAQ link does work. With the FAQ page open, clicking on the dashboard link brings me back to Terms and Conditions.

Am having same issue but for me it tells me i cant be enrolled in rewards as its for alberta and bc customers only. But i live in Edmonton alberta and have used my rewards in the past. I think the rewards page is broken at the moment 🤷‍:male_sign:

@Nicpre  I have noticed over the years you can't access your account - rewards at the end of billing cycle. You have to wait about 3 days to do anything in your account. Your problem you best get in touch with billing. I just looked at my rewards a few minutes ago. Reboot computor and remove history some times clears things up. Polecat

Ive tryed all what your saying clear the web browsers cache and history restart your pc or mobile device 🤔 . I will however try again on Tuesday after the long weekend. I just find it weird that it gives me an error saying i don't qualify for any rewards there only for bc and alberta residents. But i live in alberta lol. But ive used rewards in the past with no issues.

@Nicpre  The few problems i've had billing always solved them. Didn't put me off to long wait in one case took care of it and phoned back to make sure it was fixed. Never had much help from contact us. The neighbourhood was better. Polecat