Showing results for 
Show  only  | Search instead for 
Did you mean: 

eSIM support is finally here and it even works with a single line on the iPhone


You can purchase an eSIM voucher for $20 and complete a SIM swap using self-serve. It's just like a regular SIM swap with physical SIM cards with the only difference being the QR code scanning. Just make sure you have internet access before you scan the QR code otherwise it won't work. This applies to Koodo too. I can confirm that this works for single-line usage with the iPhone despite what it says on the TELUS eSIM voucher web page. The wording on that web page should change soon.


Also, be sure to call a TELUS/Koodo store before going there to make sure that they have eSIM vouchers in stock. Once you've swapped SIM numbers on the account, all you need to do is open the camera app and add the cellular plan. It would be a good idea to remove the physical SIM before adding a cellular plan just to avoid having to add labels for both.






I don't have a physical SIM card in my iPhone XR. It's just the eSIM on my BYOD loyalty plan ($70/15 GB).



I don't know why they said you couldn't do it.  Almost sounds like the person writing the original information didn't really know what they were doing.

@BillTelusCust wrote:

I don't know why they said you couldn't do it.  Almost sounds like the person writing the original information didn't really know what they were doing.

They were following the information on their website as well as their internal guidelines, both of which is inaccurate. I'm sure they're still parroting the wrong information to customers.

They are idiots.. I've gone to two different stores and called tech support. All have told me I NEED two phone numbers in order to have esim in my pixel 4xl. I even showed them the evoucher link and they argued with me.
So frustrating trying to change it out, I'm not sure why I have to go into an actual store.

You might want to file a complaint with the regulator....everyone should.  This is obnoxious.  

Not sure about that, finally got a voucher from a third store!
Then spent 2.5 hours on the phone with CS and TS cause if activation problems.
The account has the correct sim number on file but when it goes to download the esim it can't complete..
Pretty frustrating and I feel sorry for the staff, sounds like Telus dropped this with zero training or warning.

On the day it was supposedly launched, I passed a koodo guy going to work and made some remark about how e-sim was being launched today at Telus and Koodo. He didn't have a clue.  Telus has an awesome network but there are areas where they are going downhill way too fast - like their aggressive marketers in the malls, telephone and door-to-door as well as their wifi calling policies, and now their e-sim implementation.  It is an exercise in frustration to be sure.

Back to the Corporate store today (so far a total of approx 4 hours) to wait on hold and explain the situation over again to two new people.

New CS agent walked me through the set up again.. to the same error message. Put me on hold to speak with TS who said there was some sort of known issues with the Pixel 4's not downloading the e-sim. CS agent transferred me to TS but not the same one, so again... had to walk through everything again so the same error.. 


Now.. down 4 hours of my time, up two eSIM vouchers and back on my physical SIM card.


Way to screw up implementing something that has been in use by other carriers for some time now Telus. 


This problem is still outstanding. The service ticket number is 9566548. If they don't resolve this by tomorrow afternoon, I'm switching my personal phone line to Rogers. It's ridiculous.

I looked and apparently T-Mobile was having a problem  with them too and they needed a December update QQ1B.191205.011 - could that be your issue?

Thanks.. I'm on Jan 2020 update.

Gonna wait it out til they get their stuff sorted and give it a go again. The esim vouchers are still good so I can use them later.

Good luck/

Did a full reset as per google -


and still received the error message - called TS back and they again said it was a known issue and that I would have to 'send the phone back to google for them to force the eSIM' ??


ah... no

Ah yes, the old send 'em away routine...

Could it be that Telus needs the imei2 number associated to the account? Or set it up as a valid phone that is allowed on the network?


grasping at straws

Pretty annoying that someone hasn't set the record straight.