Showing results for 
Show  only  | Search instead for 
Did you mean: 

You need to be on your home Wifi and enter admin password to proceed

Just Moved In

Hello, I'm having trouble connecting my Telus boosters onto my home network.  My boosters are connected to the network by hardwire for the setup.  On the mobile app, when I go to "Network", "Add" (booster), this message comes up, "You need to be on your home Wi-Fi and enter your admin password to proceed.  Please ensure you're connected to your Wi-Fi and reopen the app to try again".  My cell is connected to my home network.  I can see all my home wireless devices on the app.  I tried logging out of the app and signing back in.  I also tried reinstalling the app.  Nothing worked.  Any suggestion?  Can the boosters be configured through the router: (without going through the mobile app)?  Thanks in advance.    


Community Manager
Community Manager

Hello. Have you tried 'forgetting' your home network, turning off cellular data, and then reconnecting everything to see if that works?