cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

You need to be on your home Wifi and enter admin password to proceed

dan_mah
Just Moved In

Hello, I'm having trouble connecting my Telus boosters onto my home network.  My boosters are connected to the network by hardwire for the setup.  On the mobile app, when I go to "Network", "Add" (booster), this message comes up, "You need to be on your home Wi-Fi and enter your admin password to proceed.  Please ensure you're connected to your Wi-Fi and reopen the app to try again".  My cell is connected to my home network.  I can see all my home wireless devices on the app.  I tried logging out of the app and signing back in.  I also tried reinstalling the app.  Nothing worked.  Any suggestion?  Can the boosters be configured through the router: 192.168.1.254 (without going through the mobile app)?  Thanks in advance.    

6 REPLIES 6

A-B
Community Manager
Community Manager

Hello. Have you tried 'forgetting' your home network, turning off cellular data, and then reconnecting everything to see if that works?

dgock
Just Moved In
Your suggestion didn’t work. Any other ideas?

A-B
Community Manager
Community Manager

Hmm, your best bet may then be to reach out to our Tech Support team. Have you spoken with them?

dgock
Just Moved In
I’m experiencing the same issue. Did you find a solution?

NFtoBC
Community Power User
Community Power User

Can the boosters be configured through the router: 192.168.1.254 (without going through the mobile app)?”
I have configured the Boost units in the past by finding their IP address in my router’s web admin page, then accessing the Boost web admin page by use of those found IP addresses.

NFtoBC
If you find a post useful, please give the author a "Kudo"

ChesterL
Just Moved In
Did you fix your issue already? Coz im having the same problem thanks