Showing results for 
Show  only  | Search instead for 
Did you mean: 

VPN and T3200M - GeoIP

Just Moved In

Here is my setup, T3200M, bridged to a Asus AC1750 that runs a VPN on factory software not DDWRT. Up until 6 weeks ago everything was working fine. Now, it seems that Telus either by upgrading firmware on the T3200M or something on their backend had stopped the VPN isn't allowing it to connect properly. I can still connect however, the GeoIP is being filtered out somehow, even though my VPN is on and is getting the proper IP address, it says that the GeoIP is in a completely different province and city from where I am located and where the VPN is connecting too. I have contacted the company that provides the VPN and service and they said everything is ok on their end and that it must be something the ISP is doing.

Any thoughts on this?


Community Power User
Community Power User

Sounds like you may have gotten a new IP address. Geolocation databases for IP addresses don't update frequently so if that IP was in use in another province, it will take time for that to update. That can take anywhere from 30 days to several months and is external to Telus. Which VPN are you using?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I am using NordVPN. At first I thought it was my VPN. So to test it, I tried it on my home network described previously and the issue was there. I took my laptop with the VPN software installed on it and connected straight to the T3200M and same problem. I took the laptop to my parents house since they run Telus but an older modem and launched the vpn and everything worked properly. So, that leads me to believe either the T3200M something has changed or Telus has changed something.


I have a similar problem since I switched to Telus 150. Previously I had a Zyxel single channel ADSL connection bridged to my router and it worked flawlessly with VPN sites all over the place. Despite Telus assuring me the T3200M could be bridged - it can't. It doesn't bridge (it still perfoms NAT and still assigns private IPs via DHCP). In effect your VPN is trying to go through two different routers, both performing NAT.


There is no acceptable solution offered through Telus - none of their devices can be bridged on VDSL2 accounts. The only possible solution is to supply your own VDSL2 gateway device which can be bridged. I have been trying the Zyxel VMG4325-B10A but I have no idea if it is compatible with Telus or what the correct settings are. Zyxel can only offer basic configuration support and won't deal with ISP issues.


Anyone figured this out? Telus suggested I pay more to get a slower business account which can be bridged. Also not acceptable.

Some progress to report.


I compared the Telus IGMP settings on the T3200M and was able to match them almost exactly in the Zyxel modem. I now am in bridge mode after disabling DHCP server and pulling a public IP to my own router. There is still an issue where I can only get one circuit to sync - DSL1, so I am not getting full speed.


Although I don't have service with Telus or that particular modem.  One thing that can break GeoIP is IPv6.  Try disabling that in the modem and router and see if that solves your issue.  IPv6 is much easier to trace back to you than IPv4.