Telus Gigabit internet extremely SLOW.

Just Moved In

Card), and laptop (with intel i211 gigabit Network Card) are both getting this extremely slow speed.

All these tests were conducted from a different time of the day to avoid the busy high volume load on the server-side.


Test from the (Website and Windows 10 App) for both computers is the same avg 180Mbps Download and 160 Mbps Uploads.

Test from the T3200M router's advance settings speed test avg 320Mbps Download and 250 Mbps Up.


What I tried:

- Reboot the modem

- Factory reset the modem

- Clean the Network driver, and install the new network driver.

- Asking a friend using their laptop wired to my routers ( same slow result)


Tech Support is useless they keep giving me suggestions which I already tried.

I am frustrated, coming from Shaw to Telus, decided to pay the premium for the Gigabit speed. 

I understand the speed is very YMMV there are many things that can affect the speed user actually gets. But this is just too slow.

Back when I was with Shaw (300down and 25 up), at the very least I am able to get consistent 280-290 speed every single day for the past 4 years. 


My question is If I am able the get the almost advertising speed before, what else can affect my internet speed so drastically?

I feel like I am a victim of this false advertisement when Telus won't able to help me. Why can I do it?

Community Power User
Community Power User

If you’re not getting your subscribed speed call and schedule a service call. They can do some basic troubleshooting before they would dispatch a tech.


If it’s a new install the tech would have left his business card to call, if you had any issues.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Just Moved In

I have the same Intel I211 gigabit network adapter as you and also experienced extremely slow speeds. Apparently there is a compatibility issue between the Alcatel Lucent optical network terminals (ONT) that Telus uses and some Intel network adapters.

Intel forum discussion:

Intel workaround:


The workaround involves disabling the TCP-IPv6 Checksum Offload feature. It can be applied using the provided PowerShell script or manually in Device Manager. I applied it manually and everything worked great afterwards. Hope it helps.


I got Telus Fibre 1Gig on March 5th and was getting pretty good speeds for a few days. I don't sit there and run speedtests all day everyday but my son noticed we're now only getting 50Mbit up and down.


Disconnected everything from the Telus router, rebooted and connected only 1 laptop to it.... same speed.


No outages reported in my area.


Have been on the phone almost an hour and support hasn't figured it out yet. Good thing I still got 3 weeks to cancel this rip off.