Showing results for 
Show  only  | Search instead for 
Did you mean: 

Switched from 75/75 to Gigabit plan, problem with upload speed.


I recently switched from 75/75 plan to gigabit.  With that change, my modem was swapped from the T3200 to the new Wi-Fi Hub.  This is the only hardware change in my system.

Before the change, my hardwired PC was getting consistent 80/80+ speeds using the SpeedTest app (as suggested by the technician who came for the setup.)  Now, that same PC is getting 900+ download but 0 upload through the SpeedTest app.  This is using the Telus server through SpeedTest.  If I change to any other server in SpeedTest, my results are 900/900+.  All drivers are up to date with my PC.

A touch more information: using the built-in Wi-Fi of my PC, I am achieving normal speeds of 600/600+ through SpeedTest. 

Any help of guidance is appreciated, customer support and tech support provided me with none unfortunately.



So if you are getting full speed further upstream from the Telus speedtest server, something on Telus' server is broken - and you are getting 10% less speed than you should.  Why not tell them that you "know" they are not in control of the internet, but they need to prove that their local loop is up to the speed specified.  this will force them to fix their speed test server. If you can't do a speed test on their local server, try one in another Telus location - they have several. Or try a Telus mobility one.

Might as well keep on them till they fix it.

Cheers, thanks for the advice.  I will keep on them.

I just tried your suggestion of another Telus server, one in Edmonton, with the same results.  Strong download speed and 0 upload. 

@floppydiskhero  What app are you using on your PC to test your speeds? If you go to and choose Telus as the server from the closest city to you, do you see an upload speed from your PC? It's entirely possible the app itself could be the issue. If the app shows normal upload speeds to other servers, it's likely still related to the app. Knowing which one you are using can help. Also since there are several Telus speed test servers, which city is the Telus speed test server in that you are testing to?


Try from your PC. It's very low overhead, unlike It also can easily handle gigabit+ connections. No app to spy on your PC either.


@BillTelusCust  Telus Mobility reps aren't going to be dealing with anything related to non-mobility services. The fibre tech support typically won't be able to either depending on who built the app in question and what the actual issue is. They won't have any access to the speed test server.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks for the reply.

I have used the SpeedTest app, as well as with the same results. I am choosing the Telus server for Calgary (my city) and I see an initial spike of about 1.5mbps, then it tapers off to 0mbps.  If I choose, say, Axia Connect LTD. (also in Calgary) I get 940mbps download and upload.

I have tried as well with less than favorable results.  It generally shows 400mbps download speed and 1.5mbps or lower upload speed.

I have no problems getting etc to show the upload speed to the Telus speed test server in Calgary.


It's weird didn't work for you. I tend to get more consistent results there than I do with


It sounds like your internet is working fine. 940mbps is the advertised maximum speed you'll see. The third party app/website from is more likely to be part of the issue. Speedtest also mentions on their support pages that some users antivirus or firewall could result in a zero upload speed also.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Beyond speed testing, I have noticed hangups and slow loading (sometimes not loading at all) pages in multiple browsers, as well as worse latency numbers while gaming.  Pretty disappointing really coming from 75/75 and experiencing worse performance now.  

I'll look into the firewall, however I am only using Windows 10 firewall/anti-virus and it was not causing me issues before with my previous internet package.

I wonder if this is somehow related to the IPv6 issues I've seen mentioned on Telus forums....


In general, I've had no problems with speed tests, either on mobile or fixed line.  But since Telus promised five years ago to have fiber to my home in six months, I do not have PureFibre to test that out.



Well, this has somehow sorted itself out.  My SpeedTests are showing proper results and pages are loading properly.

Thanks all for your suggestions, hopefully it stays this way.

Bringing this back because my problem has come back as of last night.  What ever the issue is it is obviously intermittent.  Very frustrating because it's affecting my ability to open web pages..