Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ethernet switch stopped working


I have been using the TP-Link TL-SG105 Ethernet switch for 18 months now without any issues.


The it plugs into the ethernet jack in the wall and then into my various devices such as my TV and my Optik PVR.


A few days ago I woke up and found that it randomly stopped working. The switch indicates that everything is working properly (everything green) but none of my devices are online.


I then tried the following fixes:


-Bought a new switch (same one, but brand new). Replaced the old switch with the new one. The issue still remained.

-Replaced all of the ethernet cables with new ones. The issue still persisted.

-Tested the connection by plugging each of the ethernet cable directly into the wall jack and then into my TV. They all successfully connected to the internet.


So the issue is the switch. But the switch isn't broken, and I bought a new one just to be sure.


Again, this worked perfectly for the past 18 months with no issue, and then out of the blue stopped working.


From what I have read online, I believe that the issue is that the switch has stopped assigning IP addresses to the devices its connected to.


Has anyone run into a similar issue?


Community Power User
Community Power User

At my previous job we had many of these switches and they would occasionally stop working for no obvious reason (power bump?). Usually all it took to get them working again was to power cycle the switch. Not sure what to suggest in your case.

Just a long time customer hoping to help.

Unmanaged switches do not assignin IP addresses. They should be transparent to the devices connected to it.
When you test the switch connect just a laptop or desktop and don't plug in any other devices.

When I connect a single device to the switch (which is connected to the wall jack) the device does not connect to the internet.

When I connect that same device to the wall jack directly, it successfully connects to the internet.

The switch is not passing through the connection, even though it used to do it for 18 months perfectly.

Tried replacing the switch with a brand new one and the issue persists.

Community Power User
Community Power User

If you can connect a computer to the switch you can try these steps to see if you can get an IP address:


How do I renew the IP address of my computer (Windows XP, Vista, 7, 8,10, Mac) | TP-Link

Just a long time customer hoping to help.