Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus TV+ New Web browser


My subscribed channels are showing as not subscribed to on the new web browser.  the channels are available on my mobile phone app and on my optic tv box,  just showing as not subscribed on the new web browser, worked on the previous version.


Community Power User
Community Power User

“The new web browser”

Given there are many web browsers, it would be helpful to know which one you are using.

It is not uncommon for the functions of new browsers to break something on a streaming platform.

If you find a post useful, please give the author a "Kudo"

Have tried, Chrome, Edge, Firefox,,, none work.  Using Windows 11.

TELUS Employee
TELUS Employee

Hi @gnoble assuming you mean the new site at - this sounds like an account synchronization issue that may need to be resolved by an agent - I'd recommend using the chat function at (happy face icon in the bottom left hand corner of your screen).

Tried that, got nowhere.  Finally call tech support, on hold for 1 hour 30 min.  Tech said they didn't know why it was not working but they are looking into it.  Put me on hold for another 1/2 an hour.  Still no solution.  Give us 24 to 48 hours to look into the issue, then call us again.

Great, no idea why, give us some more time, and call us again when you have half a day to wait on the phone.

Brutal, did they not Beta test this before going live?

I have same problem. Used to use the old telus TV app to watch shows on mybphone from time to time instead of on my TV. Now since downloading new telus TV plus app last week it is not showing all channels im subscribed to and tells me I'm not subscribed. Something wrong with the new app. Old one worked fine.

I had the same problem.

I called tech support, told them that there was a synchronization problem with my account. The tech put me on hold, re -sync’d my account and now it works fine.


I changed to TV+ on iMac on Nov12 after the upgrade email came out. No choice really; when I went to watch Optik TV  on iMac I was forced to the new TV+.

Subscribed channels did not show The Essentials - I could see them when the filter was set to ‘all channels’ but the little key logo showed on channels 100-299. Trying to watch any and I was asked to pay for the program or subscribe - to my already subscribed channels. 
Spent a couple hours with about 4 agents. Then had multiple calls by agent asking for my telus account password to investigate which I declined. Tried again Two weeks later, another two hours on phone, ticket # given, no follow up. 
Finally a friend with same issue got an agent that re-synchronized his account and fixed the ‘Essentials don’t show as subscribed channel’ problem. Took me another hour with agent who looked at the ticket, shared my iPhone camera to take screen snaps, researched the issue and finally re-synced my account.

Only took 3-weeks, 3-calls, 6-agents and about 6-hours on the phone to fix.

TELUS Employee
TELUS Employee

Hi @Black99S 


I'm really sorry about your experience - I've passed it along to a team member who helps with agent training so hopefully we can improve. During the transition from the Optik TV app to the TELUS TV+ app (and web client), there have been a small number of accounts that weren't synchronized properly for a variety of reasons (upcoming moves or orders, accounts suspended for non-payment, or more general data problems). You seem to be among the affected. While it's not a perfect solution - sometimes your 'neighbours' have similar issues and can help guide you with what may have worked for them. It's usually worth a couple of minutes to search the neighbourhood for solutions prior to calling/chatting in.


Finally, often the chat function is faster than calling and typing out your problem can remove some ambiguity, so I always recommend that.

I had trouble with new TV+ app not recognizing my subscribed channels (I posted earlier in this thread).  I had read someone else posted saying they asked for their account to be synced and then problem was fixed so I called up Telus Tech Support to tell them this.  They said they would check into it and call me back. We are now at one week and no one has every called me back; still don't get my subscribed channels.  I find this puzzling when I had even told them what the fix was supposed to be.  I really doubt this ony affects a small amount of accounts.  My account has neve had any of the changes you mention yet it still does not work on the new app.  Like I said, never a problem on old app.  How many hours does Telus expect a person to spend on phone, chats, etc. trying to fix problems with their TV, internet or phone that they did not create.  

This is brutal story: 3-weeks, 3-calls, 6-agents and about 6-hours on the phone to fix. For my similiar issue I contacted tech support, told them it appears that syncing would solve issue. They said they would investigate and call me back. More than a week and no call back; don't expect one either. Curious about the name of the agent who finally helped you get this fixed. I would love to find some way to speak with him/her as it appears Telus unable to ensure their people are sharing information in any way nor fixing the ultimate issue with the app.

Every interaction I have with Telus takes hours and hours and weeks to get resolved. In the summer and September I think I spent a total of 20 hours trying to get a simple problem with my elderly mother's cell phone account fixed.

Edmund in the Philippines solved my TV+ issue. 

Yeah, I have the same problem.

Never used Telus app before so there should not be a migration problem but while the extra channel show, the Essentials do not.

Not likely for me to attempt to fix it, as a month ago I wanted to increase my internet speed, the tech called he can't make it cause of the weather, I said no problem, he said he will fix it and set up a new time, never heard back. So I just went never mind.....I hope Rogers will be here soon (BC) (by Rogers I mean Fido)

Screenshot 2023-01-24 204543.png


Hi @KHR 

Thanks for the reply. I did start the conversation with a chat from my iMac - which became disconnected. The Agent called me back and escalated it through 3 levels until I had to end the call after an hour or more of no immediate solution. Second and third time I just called. I also searched Telus and other forums for solutions - no joy. It was only after describing the problem with another tech-savvy friend that he realized he had the same issue. He found this post thread and persevered with Telus agent until his account was re-synced and TV+ worked. I was then able to help the agent do his research and fix my problem.


I find the chats are hit and miss - many times waiting in a queue only to become disconnected after long waits or have the chat disconnect in the middle of discussing an issue. Sometimes a fast solution or answer. Been a Telus customer for 20+ years. I've used chats a lot. They are good when they work.