cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Tried to use Interac E-Transfer today to top up Prepaid account. Money is not in my account

Verzare
Just Moved In

Like the title says. I am trying to pay for my phone plan. I tried to use an interac e transfer to top up my Telus account. It is not in my account currently.

 

I am a non-verbal person and I am expecting a very important call soon that my caregiver will need to handle and I am worried that I will miss it. The money is taken off of my bank statement but is not in my account.

 

I can not call or contact Telus support. I have no phone number for the 'live agent bot' to call me back on. I have no phone number to create a twitter account to contact Twitter Telus support. The agent bot does not answer my questions.

 

Is this an on-going issue? I need help

 

Sincerely,

 

V

(They/Them)

1 REPLY 1

NFtoBC
Community Power User
Community Power User

Was today the anniversary date of your account? Transfers on the anniversary date often report in a peculiar way, but your phone should still work.

If your plan expired and therefore your phone does not work, you would need to choose a new plan as well as adding money to your account, as the plan only carries forward if renewed on or before the anniversary date.

I suggest using automatic top up, if you want an effortless top up, or add cash a few days in advance.

 

NFtoBC
If you find a post useful, please give the author a "Like"