cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Set up Amazon Prime not working in My Telus web app

cdg
Friendly Neighbour

Hello,

 

I'm trying to connect my Telus account to Amazon Prime. The Set up Amazon Prime link in the My Telus web app does nothing when I click it except for a brief flicker on the web site/browser screen. I've tried from a handful of devices (Mac, Android) and browsers (Chrome, Safari, Edge) and all result in the same behaviour. It seems like a problem with the website and not on my end. Is this a known issue?

 

Thanks.

Chris

1 ACCEPTED SOLUTION

cdg
Friendly Neighbour

I called support yesterday and the person I spoke with acknowledged the problem was on Telus' side and said it would be fixed within 24-48 hours. I ended up removing Prime from my account, so I'm not able to test whether it's working now. Good luck!

View solution in original post

13 REPLIES 13

El-Eric
Moderator
Moderator

Hey Chris, not that I am aware of but I can find out.

 

I would try incognito mode and see if that works

cdg
Friendly Neighbour

Hi El-Eric,

Thanks for looking into it. I tried in incognito mode and the same thing happens when I click the Setup Amazon Prime link - ie. nothing.

Thanks,

Chris

That's odd. Are the rest of the streaming services working fine? Were you successful in linking those?

cdg
Friendly Neighbour

Yes. I was able to successfully link my Disney+ account on the same day I first tried to link my Amazon Prime account.

 

I've had my Netflix account setup for a couple years now so I can't say whether or not I would be able to link it successfully today.

Fair enough - so the only service giving you issues is Prime.

 

I would ask that you contact our customer service team for assistance as they have steps they can follow to troubleshoot the issue.

cdg
Friendly Neighbour

I initially contacted customer care before coming here, but the person I spoke with wasn't helpful and insisted it was a problem with my Amazon account. That said, I will try again. Thanks.

I am also having the exact same issue.  Please let me know if anyone figures out how to solve it.  I have tried Incognito and multiple different browsers

KarenG218
Just Moved In

Hi. I am having exactly the same issue. Have you figured it out? Thank you

I am also having the exact same issue.  Please let me know if anyone figures out how to solve it.  I have tried Incognito and multiple different browsers

Hey @KarenG218 I recommend calling in so our customer service team can confirm the email address you are using for both and perform some troubleshooting

cdg
Friendly Neighbour

I called support yesterday and the person I spoke with acknowledged the problem was on Telus' side and said it would be fixed within 24-48 hours. I ended up removing Prime from my account, so I'm not able to test whether it's working now. Good luck!

Hello,

I upgraded my services yesterday to include Prime, and I am trying to link it to my Telus account, but it's not working.  Every time I click on it the screen just flashes and nothing happens.  I managed to link my Netflix, but not Prime.  I have already tried Incognito and multiple browsers, and I have canceled my Prime subscription on Amazon.

Please help. Thanks!

Hi @kerenmitchell - please check out our Support pages over at www.telus.com/support for additional tips and troubleshooting!