Showing results for 
Show  only  | Search instead for 
Did you mean: 

incorrect wifi password


Our struggles with telus internet continue....


Hooked up the gigabyte package last month.  Have been fighting it ever since.  For the longest time, all the devices were getting kicked off the wifi at the same time.  Nothing could reconnect until we unplugged the wifi extender and plugged it back in.


Today's challenge:  only some of the devices getting kicked off.  They cannot get back on the wifi because the device is saying "incorrect password".  Currently, I have a Samsung s9, s10, Samsung s3 tablet, iPhone 7, and dell laptop that cannot connect to the wifi because of incorrect password.  All of these devices were working fine until three hours ago.  Now none of them can get online.


I have another iPhone 7, a Samsung s7, numerous laptops, and Chromecast that are humming right along.  DIdn't get kicked off and are running fine.


On some of the devices, I've tried "forgetting" the network settings, and I've tried resetting the network settings altogether.  Cannot get the devices to connect.  I am 100% certain we are typing in the password correctly because we have numerous people checking to make sure it's correct.


Why would a device work fine all day, and then suddenly not connect to the wifi because of an "incorrect password" when NOTHING has changed.  


I'm getting so sick of fighting Telus internet.  This is getting exhausting.  Shaw was slow, but if I'd known that two months into Telus I still wouldn't have reliable internet, i never would have changed.


The tech was here two days ago and everything was running fine according to him.







Forgot to mention, everyone is connecting to the web6000Q range extender.

Community Power User
Community Power User

Skip the extender and connect directly to the Telus router wifi. Does the problem appear there also?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I've had this same problem and only connect directly to the Telus router wifi. 

Really sucky when you assume your phone is on wifi in your home and you get a cell phone bill for excess data use because your home wifi keeps dropping and saying password incorrect!!