Telus Wifi Hub manual DNS not working

Reply
Nozzy
Friendly Neighbour

Hello, I have the new Telus Wifi Hub gateway and I am trying to set it up so that it configures connected clients to use a local DNS server that I have in my LAN. I go to Network > LAN and change the DNS Server address to a local IP on my network, however, when I connect devices, they still get configured with the gateway (In my case 192.168.1.1) as the DNS server. I've restarted gateway and computer and I have also released and renewed ip to no avail.

Nozzy_0-1591154555131.png

Nozzy_1-1591154795870.png

 

 

Nozzy
Friendly Neighbour

No one has an answer?

jcbshw
Just Moved In

Not working for me either and its a pain since it renders my pihole useless

Nozzy
Friendly Neighbour

I suggest you call Telus technical support and report it so they can log it as a bug.  I did that more than a month ago so they would add it to the backlog of features/bugs they are working on. I had hopes that they would quickly fix it in a firmware update for the Telus Wifi Hub but boy was I optimistic....

ITGuy
Just Moved In

Does not work for me, I followed some advice from forums:

 

- Set DNS in the LAN

- Set DNS1 and DNS2 in the WAN

- Rebooting Hub after making entries, rebooting computers, ipconfig /release /renew etc.

 

Seems like there is no way to get the TELUS Hub to automatically set the DNS for my pihole. 

 

It is disappointing - Cira Canadian Shield or OpenDNS FamilyShield offers free DNS protection against malware, phishing, adult content and TELUS does not.  Further TELUS prevents it's customers from setting a custom DNS.......I imagine there are TELUS customers with children who would welcome the option and choice.  At least offer a paid product that gives families this protection.

snakedog116
Just Moved In

I'm having the same issue. I spoke with two different people from tech support from Telus and they both had no idea what a DNS server was and even after I explained it they said they weren't sure how to fix it. (They sent me to Port Forwarding page, and then DHCP reservations, parental controls etc.)

 

Interestingly, changing the WAN DNS server worked... but not to my pihole, only to cloudflair (since my pihole is on the LAN, not the WAN... obviously).

 

The LAN DNS server, however does nothing at all.

Nozzy
Friendly Neighbour

Thanks Snakedog, I called Telus tech support to report this bug in the hopes that they fix it in a new firmware but it has been I don't know how many months and they still have not done anything about it...  To tell you the truth, I just use my own non-Telus router now and DNS works as intended there.

MixPix
Just Moved In

Hello @Nozzy, I have the Telus WiFi Hub and this is the way to change your DNS servers.

 

IP4

1. Network left menu.

2. WAN tab.

3. Edit Button on Configure.

4. In the WAN DNS Setting area, set "Connect to DNS Server automatically" to No and the manual DNS boxes will be available. 

5. Apply Settings.

 

IP6

1. Network left menu.

2. IPv6 and then choose IPv6 again in the menu.

3. Set DNS1, DNS2.

4. Apply Settings.

 

Once you apply the DNS settings restart the router first, then all of devices on network to obtain new DNS settings.

 

Note: The DNS that you're changing in your post is for running your own DNS server on your internal network.