Showing results for 
Show  only  | Search instead for 
Did you mean: 

Port forwarding on Technicolor NH20T

Just Moved In

I residential internet with the Technicolor NH20T Modem as the "Network Access Hub" and the trash can Boost Wi-Fi 6 beneath that.


I'm trying to (re)set up port forwarding on the Technicolor NH20T to a third router (GL-MT2500 security gateway) directly beneath it. The port I'm trying to forward is UDP port 51820.


I had this config set up and working without issue since April (about 8 months). The original setup was a hassle and the port forwarding just seemed to not work even though I added the correct ruleset in the GUI. Eventually, it suddenly started working after 2-3 factory resets and reboots.


Fast forward to last week. We removed a Telus service (TV), our public IP was renewed, and then the port forwarding just stopped. And now I can't for the life of me get it working again. I've factory reset both devices (even re-flashed the GL router), set up the exact same configs, tried different ports, tried a static IP on the GL router, and the port still doesn't show as open.

I've read on Reddit and other threads here that the NH20A (and maybe T?) are super buggy with port forwarding and that the GUI will say the ruleset exists but it won't actually be open.


Does anyone have experience with this? Any ideas?


Community Manager
Community Manager

Hey @NFtoBC and @Nighthawk any thoughts on this?

Community Power User
Community Power User

@A-B The user also posted this question on Reddit and did find a possible answer as to the cause of the problem. His WAN IP and Public IP don't match. It's a CGNAT issue. 

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂