Showing results for 
Show  only  | Search instead for 
Did you mean: 

New PureFibre Customer - Plex is not working properly


So just got PureFibre installed and my plex server was functioning perfectly fine on Shaw. While plex works fine on LAN, when i, or any other users, try to use it outside my network, It is always an indirect connection. I have UPnP enabled and the proper ports are open when i look at the router. The plex server bounces between remote access being successful to unsuccessful - back and forth. However, i cannot successfully direct play a video even if I access the server during it saying remote access is working fine. I even tried turning off UPnP and port forwarding without success



Now here's the crazier thing, when i attempt to access my friend's plex server, i also get an indirect connection - his server is working fine however. When i turn off my wifi and use my 5g LTE to access his server, it connects fine and is direct play. 


What could be causing my PureFibre to make plex not work? If it was just my server that's indirect I could maybe say it was a port or windows or something... but to not work when using someone else's plex server is really odd!


I turned the firewall to "low" without change.


This is such a weird problem




We have DSL 150 and my Plex works fine except remotely on the chromecast

Oh I have no doubts that plex will work, as my friends plex server is running off telus too but seems like something is blocking it on my end

Community Power User
Community Power User

If you haven't seen this it may be of help:


Troubleshooting Remote Access | Plex Support

Just a long time customer hoping to help.

Friendly Neighbour

I have the same issue. No manual port forwarding and no auto remote connection using UPnP work. I also tried other connections, like SSH, with other ports using port forwarding with the newer fiber modem, and no luck. It seems that they seriously limited these features in the new modems. I reviewed tons of other topics and couldn't find any solution whatsoever for remote-access using a Telus home in the new PureFiber modems.

Friendly Neighbour

Yay! I finally found the issue! The "Network security" thing on the "Connect" app blocked all the requests from outside! 
Just disable it, and you're good to go!


Are you still experiencing this remote access issue? I am and still haven't figured it out. The Network Security suggestion in the TELUS Connect app only applies if you subscribe to TELUS Online Security or Wi-Fi Plus.

Yes, I've figured that the network security is applied to my case only. But that was the source of remote access in my case. I'm having no issues since I turned it off. I also removed the server from the list of devices on the profiles. You might want to try that as well cause these were the only two variables I changed and resolved the issue.