Showing results for 
Show  only  | Search instead for 
Did you mean: 

Actiontec 3200 Slow Speeds

Just Moved In

Seeing abysmal download and upload speeds with my gigabit fibre, started on Monday. Down is anywhere from 120-390mbit, up goes as low as 80mbit and as high as 300mbit.

Spent an hour with technical support on the phone the other day, and no resolution. At the time I had my dns set to and which the tech wanted me to change. That has since been changed, and unsurprisingly has not resolved my issue.

I have powercycled the actiontec 3200 router with no success, I am hardwired to the router using cat6. However from the attached screenshot you will see it is the speedtest at the router (so no computer involved) that is showing poor speeds, tech support didn't seem to be understanding me on that one.


Anyone have any ideas or how best to further escalate this?Screenshot from 2024-03-20 12-12-55.png



The train rate shows 1 Gbps which is reasonable.
What plan are you on?
Have you tried testing using a different server than Edmonton?
Have you tried running Speedtest from a browser on your computer since it's connected by Ethernet?

I am on a 1 gigabit fibre plan.

Tried all the servers, Edmonton performs the best as it is geographically closest.

I have, using the speedtest on the telus website, and, all with a hardwired cat6 connection. Results are similar, and worse in some cases.

Can you disconnect the ONT Ethernet cable from the T3200M WAN port and plug it into your PC? If so try running a speed test that way bypassing the T3200M.

I don't have fiber so I can't confirm if this possible.

Community Power User
Community Power User

One thing to note. Do not use the speedtest built in to the gateway/router. It can't handle connections over 250mbps. It's been that way for as long as I can remember.  It's best to use a more reliable one like or Try testing to either of those sites using a hardwired device and see what your actual speed is.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂