Showing results for 
Show  only  | Search instead for 
Did you mean: 

2.4ghz doesn't work

Hi. I have the Telus Smart Hub. I've tried going to and turning it on, it doesn't work. I turned off 5ghz (low and high) and 2.4 still doesn't turn on. When I look at the status overview, 2.4 doesn't have (and isn't assigned) a MAC address.

Any help or assistance would be greatly appreciated.

Community Power User
Community Power User

I don't have a Smart Hub but I believe one of the networks that can be enabled in the settings is a 2.4GHz network specifically for smart devices. If that option is still there, maybe give that a try?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Hi @Nighthawk. I tried turning it on but it doesn't broadcast the network, also I've got some other Smart Devices (ie tv) connected via Ethernet so they all need to be on the same network. 


Are my 2.4ghz settings correct? 

Enable Radio - Yes

Wireless Mode - b/g/n

Channel - 6

Bandwidth - 20MHZ


Wireless Status

Frequency -  2.4

State- Disable 

Channel - 6

SSID Broadcast - Enable

Encryption Type - WPA2-Personal


Why does Wireless 2.4 MAC Address show as 00:00:00:00:00:00??



What Modem do you have? I will try to find some answers for you.

Hi @SmoresGuy


It's an Arcadyan Telus WiFi Hub