Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why are so many recordings failing to play


TelusTV-21T Optik TV.

In the last 3 days I've had three (3) recordings that completed but would not play.


All three showed in the recording list as completed.

However, when selecting two of them I was rewarded with only a "record circle" in the right pane when selected.  As if it was asking me to record the program.   The only other option I had was to cancel the recording.

When I tried to cancel the recording, it reported and error - cannot cancel recording.  I could only remove the recording from the list by rebooting - the PC app did not even show the recording in the recording list.


The third recording just displays "Playback Error - Sorry an error has occurred. Please try again."

I was really looking forward to these recordings and put time aside to watch them - this is becoming beyond frustrating!


One was related to curling and one 1 show of my wife's that I can't remember the name of (not recorded) and one was the Formula 1 shootout (would not playback).


Edit: Clarified settop box




I've been noticing quite a number of these broken recordings in the last week.
I currently have 3 recordings showing in my "Recorded List" that simply show the empty record circle.   They are for recordings that I fully intended to watch.


They only show on the TelusTV-21T  boxes - TelusTVplus application does not show the recordings.

While trying to clean up, I thought I had removed them by rebooting but they keep reappearing.

I have that occur frequently but never bothered reporting because it's just another issue in the never ending list that don't get fixed.
For me eventually the "red circle" recordings eventually disappear.
However, I am still left to find the episode through another means,, which is very frustrating since that's what I expected the PVR function to perform in the first place.
Nothing seems to get fixed here.

TELUS Team Member
TELUS Team Member

Hi @Grimmt thank you for flagging. I reported these details to the development team and they will start an investigation!


Thanks Optik-Kate.
They have been contact with me.

Also, I noticed this morning that the recording list no longer shows the problematic recordings on the TelusTV-21T settop boxes.




I have a hunch that the problem is related to metadata changes occuring during some critical window. 


One of the recordings that showed the recording red circle had a title of "Pinty's Grand Slam of Curling".

Pinty was not the sponsor for this year's Grand Slam, so I imagine the recording slot was eventually replaced with a corrected title, which was simply "Grand Slam of Curling".    I also added this as a recording series.


My hunch is that the old recording was not modified to reflect the change and was instead left in limbo.  Perhaps the metadata editing process is missing a step that cleans up or updates existing recordings.


Update - I now have 6 Pan Continental Curling Championship episodes showing up with the empty recording circle in the TelusTV-21T android TV boxes.   These recordings do not show in the recording list when using the TelusTVplus app on my PC.


Since TSN dropped coverage of the Pan Continental Curling series mid-stream, it looks like there's an inconsistency between recordings and actual guide programs.    Maybe there's a window that causes a missing recording cleanup operation on the TelusTV-21T app after a guide programming change/edit causes a progam to be deleted from the guide. 

Side note: Although the recording entries are not  usable, I did notice that there are On-Demand versions of the programs available - maybe this is a clue to the developers for the TelusTV-21T app.


Bad recordings continue to appear in the Recording List (not the scheduled list).
The developers removed bad recordings after my previous post but new bad recordings continue to show up.


A key here again is that these recordings show on both of our TelusTV-21T boxes; they do not show on TelusTVplus applications (I confirmed on my PC and on iOS).  Also, all of these have been set up as series recordings in the past.


These bad recordings simply show a Record option with the red circle and an option to cancel the recording - which fails if selected.

1. I now have two (2) 2023 Pan Continental Curling Championships episodes left in my list.
These are collapsed under an series heading.
1a. shows as recorded "Yesterday" 4h2m - no details appear with the recording
1b. shows as recorded "Yesterday" 3h4m - no details appear with the recording


2. I have two (2) NFL Football programs
These are not collapsed under a series heading (i.e. show as 2 separate programs)
2a. shows recording of Nov5 4h7m - no details appear for the recording
2b. shows recording of Nov5 4h 27m - no details appear for the recording


3. One program of 60 Minutes recorded Nov5 1h40m - no details appear for the recording
Interestingly, I also have a separate 60 Minutes recording recorded which is good.  It shows details as S56E7 on Nov 5 for 40m.


I had this problem after I swapped some channels that were used to make the recordings. The recording would not play as I no longer subscribed to that channel, Yes it took a while to delete them. I think what works is delete and then reboot.

It is a cloud thing, they are not local like before. The cloud knows you no longer have permisssion to view that show on that channel.

Unfortunately, these recordings do not provide any play or delete options. As mentioned I only have an option to cancel the recording, which always failed.  Both rebooting and power cycle attempts did nothing to fix the recording list.


I agree this issue is likely due to some guide change that may have occurred that is missing some clean up or update step for the TelusTV-21T box.  We’ve never had this issue on the TelusTVplus apps (PC nor iOS).


After updating this thread yesterday that I continue to accumulate these bad recordings, this morning they are all cleaned up.  No bad recordings, yay!


Thanks, I assume Telus ran a cleanup routine.


This continues to be an issue with the TelusTV-21T android box.

We have gathered 4 more recordings that cannot be deleted from the recordings list.  2 x F1 Racing (17th and 18th Nov), 1 Mysteries from Above (12th Nov) and 1 Dateline (9th Nov) 


As before, only a red circle option is available.   
And also, as before, TelusTV+ apps (PC and iOS) do not show these recordings in their recording lists.


Reboots do not remove these recordings.


Did you change channels and these are recording from the previous channel you had? 

Reboot did not work? I may have also done a sign out sign in. As I do not log each move I do not know which one finally worked.

so far only recordings I have now are ones I wanted and can play


Hi Rocky3.

Are you using the TelusTV-21T android box?   
We have 2 of these setop boxes and both show these problematic recordings (the same list on each of them) - they only show a recording circle with a record/cancel option - selecting either results in a recording operation failed error.  There is no option to play, resume, delete, etc.

These recordings do not appear in the recording list if I log into the TelusTV+ apps using my PC nor my iPhone/iPad.


I have not made any changes to my programming (for example the F1 program was set up on TSN - I have all the TSN channels).


Reboots and power cycles don't fix the issue.

The TelusTV-21T android boxes are locked to Telus and I can't find any logon options - I'm pretty sure they don't require a Telus logon.  The setop box serial/key is mapped by Telus to our account.   

Edit: The Telus logout function is located in the settings->account information. At the very bottom of the information list.

Sidenote1: There is an account login option on these boxes but that is only for Google to access their play store for 3rd party apps and has nothing to do with recordings - I also removed my Google account .. just in case 🙂 .. and it had no effect.
Sidenote2: We only use one main (admin) profile.


Maybe the issue is we have 2 setop boxes and they are interacting with each other?  When I get a chance, I'll power off both at the same time and then power them both back on and see if anything changes.


Good additional info. I have one TelusTV-21T. Puzzling why PC does not show recordings. When you use the PC or phone does the icon shown the same as the one shown with the Android TelusTV box?

sign out on both devices, reboot is not the same is signing or logging out. Same as changing users on a PC without rebooting. Of course you need to know your user name and password. do both before signing back in.

I think there's a small miss-communication:

The PC and and iPhone/iPad show the normal recordings with the Play, Resume (if applicable) and Delete options.  The PC and iPhone/iPad do not show the problematic recordings that only display a recording circle.

Can you direct me to where the Telus account logon is on the TelusTV-21T - I can't find one.
I only see a Google account logon option - do you maybe mean switching profiles?

Found it.

It's at the very bottom of the account information page.

I'll try logging out and back in again.

I logged out of one of the setop boxes and back in with no change - the bad recordings are still there.
I'll need to coordinate logging out both boxes at the same time.  

I'll update tomorrow when I'm done.


I logged out of both settop boxes this morning (at the same time) and re-entered my Telus account details when prompted.   And rebooted.

This did not change the recording list - I still have the bad recordings appearing in the recording list.

Me too. I've logged out all the boxes (3) and rebooted, no change. Well actually, what I noticed was the Recorded List was either considerably shorter or empty,, but then after a while it populated back to as it was before.
These were all based on existing Scheduled recordings,, no changes had been made to the program channels or times.

Yeah, I should have mentioned that behaviour.
The family would have taken a layer of skin off me if all the recordings were lost (lol).