Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus Home Assistant not showing up in Alexa app

I am unable to find the Telus Home Assistant app in Alexa when I search for the device. The Telus rep was able to find it right away. I tried on my phone and tablet. Both are Samsung products. I removed the app and reinstalled but had no success.
Note the telus rep did not have a device paired to her account. She just downloaded the app. I am trying to get an Alexa show 8 to work with my optic account. When I searched it brought up 9988 different choices. When the telus rep tried it bought up around 2400 choices. Any help is appreciated.

Same issue. I typed in Telus Home assistant and I got 16,000 skills but none of them Telus related.


Same for me.  telus home assistant finds 10,475 results.  I guess it is looking for "telus" or " home" or "assistant".

Searching for just telus finds 1 result...City of Fort Saskatchewan....

I finally figured out the problem.  My first Echo Dot's were purchased from thus my Alexa account was based in USA and the TELUS Home Assistant skill is not offered there (same problem with Radio Player Canada and other Canadian Content providers).  I found the skill listed at . If you go there while logged it it will tell you why you cannot use it: "It looks your account is setup for"  I've moved my Alexa devices from to by following these steps and now I have TELUS Home Assistant.  I cannot link my OPTIK box yet but that is problem #2...