Showing results for 
Show  only  | Search instead for 
Did you mean: 

My ethernet port stop working on my new telus-21t dugital box

When I installed my new Telus-21T digital box, I opt to use the ethernet port as my wifi signal is not great where my TV is located. Tv service was great and fast and the ethernet port LED were happily blinking green as data was moving.
But on day 2 (& suspecting firmware update). No more TV or internet sevice on the new tv box and also No more blinking LED on the ethernet port
(Note that My wall ethernet port is working perfectly with a laptop connected to it with full speed tested)
I try to connect the tv box directly on the router without success.
Try different cables..
I did try restart and/or reset th Telus-21t.
Without success either.

The telus-22T digital box will work if i enable the WiFi. But nothing on the wired ethernet port.
Like the new tv digital box ethernet port have been disabled for good.
Is it possible?
I cannot find anything in the android setting for the ethernet port. Only WiFi enable or not.
What am I Missing?

TELUS Team Member
TELUS Team Member

Hi @Cmethot-YYC 


You internet settings can be found under Settings > Device settings > Network and Internet. If you have an ethernet connection established, that will take priority over Wi-Fi. You can turn off Wi-Fi from this menu.


If this isn't working and you've validated that your ethernet cable and everything else is fine, I'd suggest a factory reset (Settings > Device settings > Device Preferences > About > Factory Reset). Make sure that your ethernet cable is plugged in as you go through the installation process again.


I will add, have you tried a different cable with the same result

Different cables
Different laptop
Different ports
Everybody work excepted the Telus tv box ethernet port

If I may add, if factory resetting the TELUS Digital did not work, try factory resetting the modem as well.


Then ask for a replacement tuner 21T. You would not be the first to get one.