cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Edit Credit Card details - Browser security

RVan
Neighbour

Hello 

Not able to update / register credit card info on MyTelus Prepaid account
After selecting - Edit Registered credit card - Site returns the following message 

Your browser does not reach the security standards required for us to process online payments. For your protection, please use an updated browser or re-enable your browser's security settings.
We accept these browsers for online payments:
 Google Chrome 44 or higher
 Internet Explorer 11 or higher

 Firefox 40.0.2 or higher

Chrome is up to date - Version 96.0.4664.93 - also tried EDGE  - same results from 3 different computers on two different networks

Chat and live Agent support was frustrating getting this looked into 
Any body else also having seen similar issues updating payment options recently?    

1 ACCEPTED SOLUTION

New users are required to have their images approved before they are displayed to the public. This is due to issues with spammers abusing this forum. There are long time members who are exempt from this restriction.

View solution in original post

6 REPLIES 6

xray
Guardian

I'm on the payment update page now. I don't get the same messge.
Version 96.0.4664.45 (Official Build) (64-bit)

xray_0-1639160460137.png

 

I just updated to Version 96.0.4664.93 (Official Build) (64-bit) and no difference. No message for me.

RVan
Neighbour

Hello xray - thanks for taking the time to help get this sorted - (please excuse challenges resizing screen shots) 
notice the page you land on is different from my experience
I see my prepaid listed on site under Classic Mobility - Prepaid  at Telus.com/my-account
1 - Select Manage prepaid - I get redirected to mobility.telus.com/selfserveam/ConsumerPrepaid.do...

2- choose Option to register Credit card

3- select Edit registered credit card details - returns error in shot # 4  

4- "Your browser does not reach the security standards required for us to process online payments...."

e00a2936-ee1a-44e5-93f7-5f11a9d1c384.png

Looks like prepaid uses a different page for credit cards. You may need to contact customer service to see if they can do it for you. Who knows how long it may take to fix the web page. I suspect they have a coding error detecting the user agent string from the browser.

RVan
Neighbour

xray - Customer service was able to update my info on the Telus side

Thanks again 

Off topic question here for those in the know 
do you know why the image I posted above is only visible to me if I logon 
When not logged in to forum account -  Image displays only a place holder  "image_unmoderated.gif"

Your posted Images are fine when not logged in 
Thanks again ! 

New users are required to have their images approved before they are displayed to the public. This is due to issues with spammers abusing this forum. There are long time members who are exempt from this restriction.